summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-02-02 17:36:09 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-02-02 17:37:07 +0100
commitebbcc81afdcfaa490370f4c5137c660bedf54822 (patch)
tree140a6bd3ee8d0573805552f684201296ab05124e /dev-python/debugpy
parentdev-python/pydevd: add 2.9.5 (diff)
downloadgentoo-ebbcc81afdcfaa490370f4c5137c660bedf54822.tar.gz
gentoo-ebbcc81afdcfaa490370f4c5137c660bedf54822.tar.bz2
gentoo-ebbcc81afdcfaa490370f4c5137c660bedf54822.zip
dev-python/debugpy: add 1.6.6
Closes: https://bugs.gentoo.org/892707 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python/debugpy')
-rw-r--r--dev-python/debugpy/Manifest1
-rw-r--r--dev-python/debugpy/debugpy-1.6.6.ebuild43
-rw-r--r--dev-python/debugpy/files/debugpy-1.6.6-unbundle-pydevd.patch77
3 files changed, 121 insertions, 0 deletions
diff --git a/dev-python/debugpy/Manifest b/dev-python/debugpy/Manifest
index b0fc004581f0..23c020c4fa83 100644
--- a/dev-python/debugpy/Manifest
+++ b/dev-python/debugpy/Manifest
@@ -1 +1,2 @@
DIST debugpy-1.6.3.gh.tar.gz 6697583 BLAKE2B 38138be3294615e78995575c8f8ad1f990733be90cfaf76197c714e84f179086501417cc2d64627d3a8ecd0fa451e14e3229bd14d02353bc7512e288e8d4f092 SHA512 c055351351f6705b7bbab93ec07abba09027f1f2a52d90a242f51b4eb6fec19821fbb251b8c8e80587d1333faa4c6d7cab5dead938e9739c5c45013af8ee46a7
+DIST debugpy-1.6.6.gh.tar.gz 6942488 BLAKE2B 18c6eee2322239e5cbbacf9431fa7480abcf14a68f290d2228edc8b2ead042e7b09d19ee5bcc60be32e8a6b0b34b925eaa8246991298744f3ca74d4ed2ea3f3e SHA512 1a209bfd702d5f0649ce50b0910023e295953dd39cefdefb0b5af1d6023e629a727610789cd244e656bdf4276cee957fa463506ddaca603ab3ee85cc250dc212
diff --git a/dev-python/debugpy/debugpy-1.6.6.ebuild b/dev-python/debugpy/debugpy-1.6.6.ebuild
new file mode 100644
index 000000000000..8579d79609a8
--- /dev/null
+++ b/dev-python/debugpy/debugpy-1.6.6.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="An implementation of the Debug Adapter Protocol for Python"
+HOMEPAGE="https://github.com/microsoft/debugpy/ https://pypi.org/project/debugpy/"
+SRC_URI="
+ https://github.com/microsoft/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+# This is completely broken
+RESTRICT="test"
+
+RDEPEND="dev-python/pydevd[${PYTHON_USEDEP}]"
+BDEPEND="test? ( dev-python/pytest-timeout[${PYTHON_USEDEP}] )"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.6.6-unbundle-pydevd.patch"
+)
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # Drop unnecessary and unrecognized option
+ # __main__.py: error: unrecognized arguments: -n8
+ # Do not timeout
+ sed -e '/addopts/d' -e '/timeout/d' -i pytest.ini || die
+
+ # Unbundle dev-python/pydevd
+ rm -r src/debugpy/_vendored tests/tests/test_vendoring.py || die
+
+ distutils-r1_python_prepare_all
+}
diff --git a/dev-python/debugpy/files/debugpy-1.6.6-unbundle-pydevd.patch b/dev-python/debugpy/files/debugpy-1.6.6-unbundle-pydevd.patch
new file mode 100644
index 000000000000..d285775c9246
--- /dev/null
+++ b/dev-python/debugpy/files/debugpy-1.6.6-unbundle-pydevd.patch
@@ -0,0 +1,77 @@
+diff --git a/pyproject.toml b/pyproject.toml
+index 9a79e55..8725d19 100644
+--- a/pyproject.toml
++++ b/pyproject.toml
+@@ -8,7 +8,6 @@ exclude = '''
+ ( __pycache__
+ | ^/.tox
+ | ^/versioneer.py
+-| ^/src/debugpy/_vendored
+ | ^/src/debugpy/_version.py
+ )
+ '''
+diff --git a/setup.py b/setup.py
+index 3abc811..c11924c 100644
+--- a/setup.py
++++ b/setup.py
+@@ -18,12 +18,10 @@ del sys.path[0]
+
+ sys.path.insert(0, os.path.join(os.path.dirname(os.path.abspath(__file__)), "src"))
+ import debugpy
+-import debugpy._vendored
+
+ del sys.path[0]
+
+
+-PYDEVD_ROOT = debugpy._vendored.project_root("pydevd")
+ DEBUGBY_ROOT = os.path.dirname(os.path.abspath(debugpy.__file__))
+
+
+@@ -146,8 +144,6 @@ if __name__ == "__main__":
+ extras["platforms"] = platforms
+
+ cmds = versioneer.get_cmdclass()
+- override_build(cmds)
+- override_build_py(cmds)
+
+ setuptools.setup(
+ name="debugpy",
+@@ -183,14 +179,9 @@ if __name__ == "__main__":
+ "debugpy.common",
+ "debugpy.launcher",
+ "debugpy.server",
+- "debugpy._vendored",
+ ],
+ package_data={
+ "debugpy": ["ThirdPartyNotices.txt"],
+- "debugpy._vendored": [
+- # pydevd extensions must be built before this list can be computed properly,
+- # so it is populated in the overridden build_py.finalize_options().
+- ],
+ },
+ ext_modules=ExtModules(),
+ has_ext_modules=lambda: True,
+diff --git a/src/debugpy/server/__init__.py b/src/debugpy/server/__init__.py
+index 42d5367..e333dcf 100644
+--- a/src/debugpy/server/__init__.py
++++ b/src/debugpy/server/__init__.py
+@@ -1,7 +1,3 @@
+ # Copyright (c) Microsoft Corporation. All rights reserved.
+ # Licensed under the MIT License. See LICENSE in the project root
+ # for license information.
+-
+-# "force_pydevd" must be imported first to ensure (via side effects)
+-# that the debugpy-vendored copy of pydevd gets used.
+-import debugpy._vendored.force_pydevd # noqa
+diff --git a/src/debugpy/server/attach_pid_injected.py b/src/debugpy/server/attach_pid_injected.py
+index a8df6e1..a29a969 100644
+--- a/src/debugpy/server/attach_pid_injected.py
++++ b/src/debugpy/server/attach_pid_injected.py
+@@ -31,7 +31,6 @@ def attach(setup):
+ pydevd_attach_to_process_path = os.path.join(
+ _debugpy_dir,
+ "debugpy",
+- "_vendored",
+ "pydevd",
+ "pydevd_attach_to_process",
+ )