summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-06-13 08:08:13 +0200
committerMichał Górny <mgorny@gentoo.org>2022-06-13 09:18:46 +0200
commit1e4edb8f3bf41b76fcc61e653742c47c2965cbc3 (patch)
tree4a139a59c24c596213d9e421e20e43b72bc938ef /dev-python/cvxopt
parentdev-python/daemonize: Enable py3.11 (diff)
downloadgentoo-1e4edb8f3bf41b76fcc61e653742c47c2965cbc3.tar.gz
gentoo-1e4edb8f3bf41b76fcc61e653742c47c2965cbc3.tar.bz2
gentoo-1e4edb8f3bf41b76fcc61e653742c47c2965cbc3.zip
dev-python/cvxopt: Enable py3.11
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/cvxopt')
-rw-r--r--dev-python/cvxopt/cvxopt-1.3.0.ebuild25
1 files changed, 19 insertions, 6 deletions
diff --git a/dev-python/cvxopt/cvxopt-1.3.0.ebuild b/dev-python/cvxopt/cvxopt-1.3.0.ebuild
index c9d48eb76775..f8f880b1f16e 100644
--- a/dev-python/cvxopt/cvxopt-1.3.0.ebuild
+++ b/dev-python/cvxopt/cvxopt-1.3.0.ebuild
@@ -4,12 +4,20 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( python3_{8..11} )
+
inherit distutils-r1 toolchain-funcs
DESCRIPTION="Python package for convex optimization"
-HOMEPAGE="https://cvxopt.org/ https://github.com/cvxopt/cvxopt"
-SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+HOMEPAGE="
+ https://cvxopt.org/
+ https://github.com/cvxopt/cvxopt/
+ https://pypi.org/project/cvxopt/
+"
+SRC_URI="
+ https://github.com/${PN}/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz
+"
LICENSE="GPL-3"
SLOT="0"
@@ -27,9 +35,14 @@ DEPEND="
dsdp? ( sci-libs/dsdp:0= )
fftw? ( sci-libs/fftw:3.0= )
glpk? ( >=sci-mathematics/glpk-4.49:0= )
- gsl? ( sci-libs/gsl:0= )"
-RDEPEND="${DEPEND}"
-BDEPEND="virtual/pkgconfig"
+ gsl? ( sci-libs/gsl:0= )
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ virtual/pkgconfig
+"
PATCHES=( "${FILESDIR}/cvxopt-1.3.0-versioneer-buildfix.patch" )