summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-22 08:41:31 +0200
committerMichał Górny <mgorny@gentoo.org>2023-10-22 08:55:31 +0200
commite7602114f2c425f4a1af2e61a074fc997be92387 (patch)
tree8a73a418a23bf06e6817b5070554bfb0f5ce0cf0 /dev-python/css-parser
parentdev-python/django-configurations: Bump to 2.5 (diff)
downloadgentoo-e7602114f2c425f4a1af2e61a074fc997be92387.tar.gz
gentoo-e7602114f2c425f4a1af2e61a074fc997be92387.tar.bz2
gentoo-e7602114f2c425f4a1af2e61a074fc997be92387.zip
dev-python/css-parser: Bump to 1.0.10
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/css-parser')
-rw-r--r--dev-python/css-parser/Manifest1
-rw-r--r--dev-python/css-parser/css-parser-1.0.10.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/css-parser/Manifest b/dev-python/css-parser/Manifest
index 4b5a1d2a81e9..920fe384ee8c 100644
--- a/dev-python/css-parser/Manifest
+++ b/dev-python/css-parser/Manifest
@@ -1 +1,2 @@
+DIST css-parser-1.0.10.tar.gz 349673 BLAKE2B 30ba106620e488532d3cfbd84fc44b0bc15f1e98c7ca3db5a04476810f1bd7ff62c425a052e141a2f13d15e30bd8d1ad83bf769ccce256bef5b723560e230810 SHA512 1f339eb5771fb1ff2f2fc5dbcbe86f6ad09d0ae1abeca96194e6d3c0c4e385ae7366618f28d01010e764fa81d30aec7ccfcbeea2a084c8528be33812307149c8
DIST css-parser-1.0.9.tar.gz 349482 BLAKE2B b3ea0e6f10179882827e614837fc109fb9fe926a05fb497c1dd6239e289cf712512d86bb3974adba41cc4bbd0babf623a637604a676b6725dd1e9b49c53c3170 SHA512 487213f870066b2264ec4d7ee4a41819fe2c92187c64557ea011c1a24fbdf623e802ab6a3a828e5e5d23c3d684344b64805676d15837d421a85fba28771af664
diff --git a/dev-python/css-parser/css-parser-1.0.10.ebuild b/dev-python/css-parser/css-parser-1.0.10.ebuild
new file mode 100644
index 000000000000..2473bba51393
--- /dev/null
+++ b/dev-python/css-parser/css-parser-1.0.10.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A CSS Cascading Style Sheets library (fork of cssutils)"
+HOMEPAGE="
+ https://github.com/ebook-utils/css-parser/
+ https://pypi.org/project/css-parser/
+"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~riscv ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/chardet[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest