summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-02-25 12:39:13 +0100
committerMichał Górny <mgorny@gentoo.org>2021-02-25 14:24:41 +0100
commitfb7f3c1c5d542fabd731d3a61bb804b7dd18dad2 (patch)
treec01e17fdc07d381821d467fa7128e77159fa8add /dev-python/clang-python/clang-python-12.0.0_rc2.ebuild
parentsys-devel/clang: Remove 12.0.0_rc2 (diff)
downloadgentoo-fb7f3c1c5d542fabd731d3a61bb804b7dd18dad2.tar.gz
gentoo-fb7f3c1c5d542fabd731d3a61bb804b7dd18dad2.tar.bz2
gentoo-fb7f3c1c5d542fabd731d3a61bb804b7dd18dad2.zip
dev-python/clang-python: Remove 12.0.0_rc2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/clang-python/clang-python-12.0.0_rc2.ebuild')
-rw-r--r--dev-python/clang-python/clang-python-12.0.0_rc2.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/clang-python/clang-python-12.0.0_rc2.ebuild b/dev-python/clang-python/clang-python-12.0.0_rc2.ebuild
new file mode 100644
index 000000000000..39e999e67709
--- /dev/null
+++ b/dev-python/clang-python/clang-python-12.0.0_rc2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+inherit llvm.org python-r1
+
+DESCRIPTION="Python bindings for sys-devel/clang"
+HOMEPAGE="https://llvm.org/"
+
+LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
+SLOT="0"
+KEYWORDS=""
+IUSE="test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+RESTRICT="!test? ( test )"
+
+# The module is opening libclang.so directly, and doing some blasphemy
+# on top of it.
+RDEPEND="
+ >=sys-devel/clang-${PV}:*
+ !sys-devel/llvm:0[clang(-),python(-)]
+ !sys-devel/clang:0[python(-)]
+ ${PYTHON_DEPS}"
+DEPEND="${RDEPEND}"
+
+LLVM_COMPONENTS=( clang/bindings/python )
+llvm.org_set_globals
+
+python_test() {
+ "${EPYTHON}" -m unittest discover -v || die "Tests fail with ${EPYTHON}"
+}
+
+src_test() {
+ python_foreach_impl python_test
+}
+
+src_install() {
+ python_foreach_impl python_domodule clang
+}