summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-10-15 08:43:10 +0200
committerJustin Lecher <jlec@gentoo.org>2015-10-15 10:18:22 +0200
commiteaefe8a11c1909c58ad2b6bfd35c743f44633b42 (patch)
tree7313d905a38b9b77a1daeeebb6d5669d2dfc6777 /dev-python/capturer
parentsys-cluster/cinder: liberty bup (diff)
downloadgentoo-eaefe8a11c1909c58ad2b6bfd35c743f44633b42.tar.gz
gentoo-eaefe8a11c1909c58ad2b6bfd35c743f44633b42.tar.bz2
gentoo-eaefe8a11c1909c58ad2b6bfd35c743f44633b42.zip
dev-python/capturer: New package, ebuild written by me
Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/capturer')
-rw-r--r--dev-python/capturer/Manifest1
-rw-r--r--dev-python/capturer/capturer-2.1.ebuild32
-rw-r--r--dev-python/capturer/metadata.xml13
3 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/capturer/Manifest b/dev-python/capturer/Manifest
new file mode 100644
index 000000000000..a4a8ea3a5228
--- /dev/null
+++ b/dev-python/capturer/Manifest
@@ -0,0 +1 @@
+DIST capturer-2.1.tar.gz 17380 SHA256 6837c34651d50615e20281a1cc73a2b363bb7b7c9451003d08ea481a58a6bbb8 SHA512 30325a4908b63cdc63439fe2dab360f37db1f335d44ba10cf03294513cf2ffd6688843659d16b6c96bca44440fbbf607b8b20c5031ee99b8973a26460e37ff72 WHIRLPOOL 47a3f37e200c4c7100baba4acc0dd3bf443e634b4d85d25e50e09a7db28477966a0247c85e0365d0b53d74c5247d4d0fcfc455ca77e5d0c743f410e61d6c588f
diff --git a/dev-python/capturer/capturer-2.1.ebuild b/dev-python/capturer/capturer-2.1.ebuild
new file mode 100644
index 000000000000..46af8fcbd1ce
--- /dev/null
+++ b/dev-python/capturer/capturer-2.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Easily capture stdout/stderr of the current process and subprocesses"
+HOMEPAGE="https://capturer.readthedocs.org/ https://pypi.python.org/pypi/capturer https://github.com/xolox/python-capturer"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+
+# Test fails only ebuild, but works manually
+# Can't find out what it is
+RESTRICT=test
+
+python_test() {
+ esetup.py test
+}
diff --git a/dev-python/capturer/metadata.xml b/dev-python/capturer/metadata.xml
new file mode 100644
index 000000000000..6d57e9c7e6d8
--- /dev/null
+++ b/dev-python/capturer/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ <name>Justin Lecher</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">coloredlogs</remote-id>
+ <remote-id type="github">xolox/python-coloredlogs</remote-id>
+ </upstream>
+</pkgmetadata>