summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-04-05 10:19:04 +0200
committerMichał Górny <mgorny@gentoo.org>2023-04-05 10:19:04 +0200
commit8ccab891cfe12fd35101f52e9b667964df5e883f (patch)
treeb79846b55c635f7dfb0f78d0259c601568e63623 /dev-python/breathe
parentdev-python/requests-cache: Remove old (diff)
downloadgentoo-8ccab891cfe12fd35101f52e9b667964df5e883f.tar.gz
gentoo-8ccab891cfe12fd35101f52e9b667964df5e883f.tar.bz2
gentoo-8ccab891cfe12fd35101f52e9b667964df5e883f.zip
dev-python/breathe: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/breathe')
-rw-r--r--dev-python/breathe/Manifest1
-rw-r--r--dev-python/breathe/breathe-4.34.0.ebuild41
-rw-r--r--dev-python/breathe/files/breathe-4.34.0-sphinx-5.3.0.patch43
3 files changed, 0 insertions, 85 deletions
diff --git a/dev-python/breathe/Manifest b/dev-python/breathe/Manifest
index f25583217989..a14e4d4d735f 100644
--- a/dev-python/breathe/Manifest
+++ b/dev-python/breathe/Manifest
@@ -1,2 +1 @@
-DIST breathe-4.34.0.gh.tar.gz 206989 BLAKE2B 1c899165ae30de373f90c0fd0b3428d7f4d74e3f66720731c2d02bc2a8bd9c6e5bbd81909b8ab186304975f877d276ed0170c611105335032bee3b689cadef73 SHA512 7f3134575f1b8c4d7c96ebc735e33f656b5c6046de3fa2aee95d5e895fb33f0a83fb4b1c64dd69b9deca20b785868b42d6b1d5e39741500ff5f9d82bf3f130b4
DIST breathe-4.35.0.gh.tar.gz 212932 BLAKE2B 9423cc99cd1dc45fa1c93f1e2adfe59be4f3398842d3c6f98ee7a17285e108de4eb88e149c4ee179fa1008e30b69c8fa4f3934506aa53892c2eb612fa7652ba3 SHA512 76e36fceb89c21e2c62471a37b856f8e7077f946ca8ebffdd068297d7d447ba4f42f8f9d91e231f7a181d7dba2cb8650479f35f8bef342184e5ccbd3dd951f91
diff --git a/dev-python/breathe/breathe-4.34.0.ebuild b/dev-python/breathe/breathe-4.34.0.ebuild
deleted file mode 100644
index f5520f4e516f..000000000000
--- a/dev-python/breathe/breathe-4.34.0.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="Sphinx Doxygen renderer"
-HOMEPAGE="
- https://breathe.readthedocs.io/en/latest/
- https://github.com/breathe-doc/breathe/
- https://pypi.org/project/breathe/
-"
-SRC_URI="
- https://github.com/breathe-doc/breathe/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux"
-
-RDEPEND="
- app-doc/doxygen
- dev-python/docutils[${PYTHON_USEDEP}]
- >=dev-python/sphinx-4.0.0[${PYTHON_USEDEP}]
- dev-texlive/texlive-bibtexextra
- dev-texlive/texlive-fontsextra
- dev-texlive/texlive-fontutils
- dev-texlive/texlive-latex
- dev-texlive/texlive-latexextra
-"
-
-distutils_enable_tests pytest
-
-PATCHES=(
- "${FILESDIR}"/${P}-sphinx-5.3.0.patch
-)
diff --git a/dev-python/breathe/files/breathe-4.34.0-sphinx-5.3.0.patch b/dev-python/breathe/files/breathe-4.34.0-sphinx-5.3.0.patch
deleted file mode 100644
index 52c65b99ec4a..000000000000
--- a/dev-python/breathe/files/breathe-4.34.0-sphinx-5.3.0.patch
+++ /dev/null
@@ -1,43 +0,0 @@
-From 877d88e5aecd1d39978a46fe7f3df35474d7cd8d Mon Sep 17 00:00:00 2001
-From: Daniel Garcia Moreno <daniel.garcia@suse.com>
-Date: Fri, 28 Oct 2022 08:45:33 +0200
-Subject: [PATCH] Fix tests for Sphinx 5.3.0
-
-Fix https://github.com/breathe-doc/breathe/issues/863
----
- tests/test_renderer.py | 12 +++++++++++-
- 1 file changed, 11 insertions(+), 1 deletion(-)
-
-diff --git a/tests/test_renderer.py b/tests/test_renderer.py
-index 1688981..a858c65 100644
---- a/tests/test_renderer.py
-+++ b/tests/test_renderer.py
-@@ -109,6 +109,12 @@ class WrappedCompoundDef(compounddefTypeSub, WrappedDoxygenNode):
- WrappedDoxygenNode.__init__(self, compounddefTypeSub, **kwargs)
-
-
-+class MockMemo:
-+ def __init__(self):
-+ self.title_styles = ""
-+ self.section_level = ""
-+
-+
- class MockState:
- def __init__(self, app):
- from breathe.project import ProjectInfoFactory
-@@ -123,7 +129,11 @@ class MockState:
- settings.env = env
- self.document = utils.new_document("", settings)
-
-- def nested_parse(self, content, content_offset, contentnode):
-+ # In sphinx 5.3.0 the method state.nested_parse is not called directly
-+ # so this memo object should exists here
-+ self.memo = MockMemo()
-+
-+ def nested_parse(self, content, content_offset, contentnode, match_titles=1):
- pass
-
-
---
-2.39.0
-