summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDenis Dupeyron <calchan@gentoo.org>2018-12-30 19:27:24 -0700
committerDenis Dupeyron <calchan@gentoo.org>2018-12-30 19:27:24 -0700
commite9d7b9e2dec49e4f5c7f485650b48d7f4d22edb2 (patch)
treebece4de00e91c5ae73c1b0ef5ea5393499bdd0f2 /dev-python/autopep8/autopep8-1.4.3.ebuild
parentapp-office/libreoffice: Add 6.2 stable branch (diff)
downloadgentoo-e9d7b9e2dec49e4f5c7f485650b48d7f4d22edb2.tar.gz
gentoo-e9d7b9e2dec49e4f5c7f485650b48d7f4d22edb2.tar.bz2
gentoo-e9d7b9e2dec49e4f5c7f485650b48d7f4d22edb2.zip
dev-python/autopep8: bump to 1.4.3
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Denis Dupeyron <calchan@gentoo.org>
Diffstat (limited to 'dev-python/autopep8/autopep8-1.4.3.ebuild')
-rw-r--r--dev-python/autopep8/autopep8-1.4.3.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/autopep8/autopep8-1.4.3.ebuild b/dev-python/autopep8/autopep8-1.4.3.ebuild
new file mode 100644
index 000000000000..547637d8dc38
--- /dev/null
+++ b/dev-python/autopep8/autopep8-1.4.3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} pypy{,3} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Automatically formats Python code to conform to the PEP 8 style guide"
+HOMEPAGE="https://github.com/hhatto/autopep8 https://pypi.org/project/autopep8/"
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/hhatto/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/pep8-1.5.7[${PYTHON_USEDEP}]
+ >=dev-python/pycodestyle-2.3[${PYTHON_USEDEP}]"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ >=dev-python/pydiff-0.1.2[${PYTHON_USEDEP}]
+ )"
+
+python_prepare_all() {
+ # Prevent UnicodeDecodeError with LANG=C
+ sed -e "/é/d" -i MANIFEST.in || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ esetup.py test
+}