summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-12-20 23:11:21 +0100
committerMichał Górny <mgorny@gentoo.org>2021-12-21 00:10:25 +0100
commit4df1b49d9af991d4638524435d3d3c411d380e10 (patch)
treef10b26e54d80fd45f001b00d52b64758bacdfafe /dev-python/async_timeout/async_timeout-4.0.2.ebuild
parentdev-python/setuptools: Bump to 60.0.2 (diff)
downloadgentoo-4df1b49d9af991d4638524435d3d3c411d380e10.tar.gz
gentoo-4df1b49d9af991d4638524435d3d3c411d380e10.tar.bz2
gentoo-4df1b49d9af991d4638524435d3d3c411d380e10.zip
dev-python/async_timeout: Bump to 4.0.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/async_timeout/async_timeout-4.0.2.ebuild')
-rw-r--r--dev-python/async_timeout/async_timeout-4.0.2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/async_timeout/async_timeout-4.0.2.ebuild b/dev-python/async_timeout/async_timeout-4.0.2.ebuild
new file mode 100644
index 000000000000..2f3850143bcd
--- /dev/null
+++ b/dev-python/async_timeout/async_timeout-4.0.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+MY_P=${PN/_/-}-${PV}
+DESCRIPTION="Timeout context manager for asyncio programs"
+HOMEPAGE="https://github.com/aio-libs/async-timeout"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~x64-macos"
+
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-aiohttp[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # remove pointless dep on pytest-cov
+ sed -i -e '/addopts/d' setup.cfg || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ epytest -p no:aiohttp
+}