summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-07-06 08:36:01 +0200
committerMichał Górny <mgorny@gentoo.org>2024-07-06 08:36:01 +0200
commit73343b358409494b0d622207d1075ae130a6ffe0 (patch)
treea403022e1ae8e7b2d81178b4395ebbb63436d897 /dev-python/argcomplete
parentdev-python/backrefs: Remove old (diff)
downloadgentoo-73343b358409494b0d622207d1075ae130a6ffe0.tar.gz
gentoo-73343b358409494b0d622207d1075ae130a6ffe0.tar.bz2
gentoo-73343b358409494b0d622207d1075ae130a6ffe0.zip
dev-python/argcomplete: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/argcomplete')
-rw-r--r--dev-python/argcomplete/Manifest1
-rw-r--r--dev-python/argcomplete/argcomplete-3.3.0.ebuild45
-rw-r--r--dev-python/argcomplete/files/argcomplete-3.3.0-test-bashrc.patch13
3 files changed, 0 insertions, 59 deletions
diff --git a/dev-python/argcomplete/Manifest b/dev-python/argcomplete/Manifest
index 15c169b0b93e..13a5306894b2 100644
--- a/dev-python/argcomplete/Manifest
+++ b/dev-python/argcomplete/Manifest
@@ -1,2 +1 @@
-DIST argcomplete-3.3.0.tar.gz 81832 BLAKE2B 63778dc48f90bb06dbf59c8d4d94ca905c9b188ec5b64e3a8cf7604d66cf075b31350f241da00e460d97b1920c620d4fbf8df772485987897a698cec060b6ec9 SHA512 30776b7e2dc3ee1f7dfcd665d2ae6e403b09644829c1cd7a30ce80e39c6bd7331cc0b7bd7d6cec58a409ef6ec209ca6b1cca0888e83a7a9a228658fa72f6e578
DIST argcomplete-3.4.0.tar.gz 82275 BLAKE2B 18b81aa5ee0c148a3b935f157f4c39b0ade79b36c8e3aa94aa7af8a424a08793a4cf661cb2431c201d5eead02e12c35b78d351310ff4e4e750bf7d7dc702ca89 SHA512 bd619a34edf1f1d05bdfab7fa830d1fc5375bc292dc95b95ddc4d3bfaced5728067e6ad0a901f672b7e0d5a550c10b00e0851f83cf9b358301c037da256a4a56
diff --git a/dev-python/argcomplete/argcomplete-3.3.0.ebuild b/dev-python/argcomplete/argcomplete-3.3.0.ebuild
deleted file mode 100644
index 9f27971130b6..000000000000
--- a/dev-python/argcomplete/argcomplete-3.3.0.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..13} pypy3 )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Bash tab completion for argparse"
-HOMEPAGE="
- https://github.com/kislyuk/argcomplete/
- https://pypi.org/project/argcomplete/
-"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~x64-macos"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-# pip is called as an external tool
-BDEPEND="
- test? (
- app-shells/fish
- app-shells/tcsh
- app-shells/zsh
- dev-python/pexpect[${PYTHON_USEDEP}]
- >=dev-python/pip-19
- )
-"
-
-PATCHES=(
- # increase test timeouts -- this is particularly necessary
- # for entry point tests because they read metadata of all installed
- # packages which can take real long on systems with lots of packages
- "${FILESDIR}/argcomplete-3.1.6-timeout.patch"
- # https://github.com/kislyuk/argcomplete/pull/485
- "${FILESDIR}/${P}-test-bashrc.patch"
-)
-
-python_test() {
- "${EPYTHON}" test/test.py -v || die
-}
diff --git a/dev-python/argcomplete/files/argcomplete-3.3.0-test-bashrc.patch b/dev-python/argcomplete/files/argcomplete-3.3.0-test-bashrc.patch
deleted file mode 100644
index 0e9f2fa1cea6..000000000000
--- a/dev-python/argcomplete/files/argcomplete-3.3.0-test-bashrc.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/test/test.py b/test/test.py
-index c8f9419..ca38be6 100755
---- a/test/test.py
-+++ b/test/test.py
-@@ -73,7 +73,7 @@ def _repl_sh(command, args, non_printable_insert):
-
-
- def bash_repl(command="bash"):
-- bashrc = os.path.join(os.path.dirname(pexpect.__file__), "replwrap", "bashrc.sh")
-+ bashrc = os.path.join(os.path.dirname(pexpect.__file__), "bashrc.sh")
- sh = _repl_sh(command, ["--rcfile", bashrc], non_printable_insert="\\[\\]")
- return sh
-