summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2017-11-18 14:12:40 -0500
committerTim Harder <radhermit@gentoo.org>2017-11-18 21:49:53 -0500
commitb6d878c1953cb701d0ec8208cc905c6457116950 (patch)
tree596559af758e48dd7b79d4cd9e9763ea76ea415a /dev-python/apsw/apsw-3.21.0_p1.ebuild
parentdev-python/llfuse: version bump to 1.3.2 (diff)
downloadgentoo-b6d878c1953cb701d0ec8208cc905c6457116950.tar.gz
gentoo-b6d878c1953cb701d0ec8208cc905c6457116950.tar.bz2
gentoo-b6d878c1953cb701d0ec8208cc905c6457116950.zip
dev-python/apsw: version bump to 3.21.0_p1
Diffstat (limited to 'dev-python/apsw/apsw-3.21.0_p1.ebuild')
-rw-r--r--dev-python/apsw/apsw-3.21.0_p1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/apsw/apsw-3.21.0_p1.ebuild b/dev-python/apsw/apsw-3.21.0_p1.ebuild
new file mode 100644
index 000000000000..f2bb6b9990b9
--- /dev/null
+++ b/dev-python/apsw/apsw-3.21.0_p1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1 flag-o-matic
+
+MY_PV=${PV/_p/-r}
+MY_P=${PN}-${MY_PV}
+
+DESCRIPTION="APSW - Another Python SQLite Wrapper"
+HOMEPAGE="https://github.com/rogerbinns/apsw/"
+SRC_URI="https://github.com/rogerbinns/apsw/releases/download/${MY_PV}/${MY_P}.zip -> ${P}.zip"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc64 ~x86"
+IUSE="doc"
+
+RDEPEND=">=dev-db/sqlite-${PV%_p*}"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S=${WORKDIR}/${MY_P}
+
+PATCHES=( "${FILESDIR}/${PN}-3.6.20.1-fix_tests.patch" )
+
+python_compile() {
+ python_is_python3 || append-cflags -fno-strict-aliasing
+ distutils-r1_python_compile --enable=load_extension
+}
+
+python_test() {
+ "${PYTHON}" setup.py build_test_extension || die "Building of test loadable extension failed"
+ "${PYTHON}" tests.py -v || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/. )
+ distutils-r1_python_install_all
+}