summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-13 07:38:22 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-13 08:15:23 +0200
commit5b472e557bb7f9adf888d1e0a69148e9773ffc17 (patch)
tree896adee5aeb97e2d228c34848c9e38f150272bce /dev-python/apispec
parentdev-python/apispec: Remove old (diff)
downloadgentoo-5b472e557bb7f9adf888d1e0a69148e9773ffc17.tar.gz
gentoo-5b472e557bb7f9adf888d1e0a69148e9773ffc17.tar.bz2
gentoo-5b472e557bb7f9adf888d1e0a69148e9773ffc17.zip
dev-python/apispec: Bump to 5.2.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/apispec')
-rw-r--r--dev-python/apispec/Manifest1
-rw-r--r--dev-python/apispec/apispec-5.2.2.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/apispec/Manifest b/dev-python/apispec/Manifest
index 6ceb2fb5ffe3..8fb69b834771 100644
--- a/dev-python/apispec/Manifest
+++ b/dev-python/apispec/Manifest
@@ -1 +1,2 @@
DIST apispec-5.2.1.gh.tar.gz 71348 BLAKE2B c908fb3741e72d0e8a3dfd70c186255cb5862f7c51c32c5c54ea3cba38a7ce9e02143e029a505f30f284f7b5490946897fead535a9a8743549806aacd1c7791d SHA512 020d377e4dd9e2e3514cf48450bee9a5b957cb0d419f7fa4da35691b68cd108673b133d4ad07b908ca377b1418d087979eea409382ca743d350aec95b796f00f
+DIST apispec-5.2.2.gh.tar.gz 71563 BLAKE2B 205c796ccee03000626538147d6cb26a72242ba8ffd6df47b6a7bdb82f0e2ee1d5421cb7da045fc177297acb838e7351ae996225a43c3c7a57a0a0d72e098bb1 SHA512 16c6229619853671403e81edaa50ce87c2575cdb6c606502e08c086aa33b25db0cef0cd455c2c74a55138eaf95667f7ffe9ac8045cbeb415df4b623878a8831c
diff --git a/dev-python/apispec/apispec-5.2.2.ebuild b/dev-python/apispec/apispec-5.2.2.ebuild
new file mode 100644
index 000000000000..e56c46d972d1
--- /dev/null
+++ b/dev-python/apispec/apispec-5.2.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A pluggable API specification generator"
+HOMEPAGE="
+ https://github.com/marshmallow-code/apispec/
+ https://pypi.org/project/apispec/
+"
+SRC_URI="
+ https://github.com/marshmallow-code/apispec/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/pyyaml-3.10[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/bottle[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ >=dev-python/marshmallow-3.13.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ dev-python/sphinx-issues \
+ dev-python/sphinx_rtd_theme
+
+EPYTEST_DESELECT=(
+ # requires unpackaged prance
+ tests/test_ext_marshmallow_openapi.py::test_openapi_tools_validate_v2
+ tests/test_ext_marshmallow_openapi.py::test_openapi_tools_validate_v3
+)