summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHaelwenn (lanodan) Monnier <contact@hacktivis.me>2019-11-23 10:10:13 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-04-03 22:05:25 +0200
commitfbc7f8b68d6a4388cdd7ed8d93d1e232d181d44e (patch)
treeb72d35f148b767e848b133af35ae20f85e79b345 /dev-python/PyQt5
parentdev-qt/qtgui: rename USE=gles2 to USE=gles2-only (diff)
downloadgentoo-fbc7f8b68d6a4388cdd7ed8d93d1e232d181d44e.tar.gz
gentoo-fbc7f8b68d6a4388cdd7ed8d93d1e232d181d44e.tar.bz2
gentoo-fbc7f8b68d6a4388cdd7ed8d93d1e232d181d44e.zip
dev-python/PyQt5: rename USE=gles2 to USE=gles2-only
Signed-off-by: Haelwenn (lanodan) Monnier <contact@hacktivis.me> Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-python/PyQt5')
-rw-r--r--dev-python/PyQt5/PyQt5-5.13.2-r1.ebuild (renamed from dev-python/PyQt5/PyQt5-5.13.2.ebuild)8
-rw-r--r--dev-python/PyQt5/PyQt5-5.14.1-r1.ebuild (renamed from dev-python/PyQt5/PyQt5-5.14.1.ebuild)8
-rw-r--r--dev-python/PyQt5/metadata.xml1
3 files changed, 8 insertions, 9 deletions
diff --git a/dev-python/PyQt5/PyQt5-5.13.2.ebuild b/dev-python/PyQt5/PyQt5-5.13.2-r1.ebuild
index bb4a3e363f4e..4b62cb093011 100644
--- a/dev-python/PyQt5/PyQt5-5.13.2.ebuild
+++ b/dev-python/PyQt5/PyQt5-5.13.2-r1.ebuild
@@ -21,7 +21,7 @@ SLOT="0"
KEYWORDS="amd64 arm arm64 ~ppc ~ppc64 x86"
# TODO: QtNfc, QtRemoteObjects (Qt >= 5.12)
-IUSE="bluetooth dbus debug declarative designer examples gles2 gui help location multimedia
+IUSE="bluetooth dbus debug declarative designer examples gles2-only gui help location multimedia
network networkauth opengl positioning printsupport sensors serialport sql +ssl svg
testlib webchannel webkit websockets widgets x11extras xmlpatterns"
@@ -69,7 +69,7 @@ RDEPEND="
)
declarative? ( >=dev-qt/qtdeclarative-${QT_PV}[widgets?] )
designer? ( >=dev-qt/designer-${QT_PV} )
- gui? ( >=dev-qt/qtgui-${QT_PV}[gles2=] )
+ gui? ( >=dev-qt/qtgui-${QT_PV}[gles2-only=] )
help? ( >=dev-qt/qthelp-${QT_PV} )
location? ( >=dev-qt/qtlocation-${QT_PV} )
multimedia? ( >=dev-qt/qtmultimedia-${QT_PV}[widgets?] )
@@ -128,9 +128,9 @@ src_configure() {
$(usex declarative '' --no-qml-plugin)
$(pyqt_use_enable designer)
$(usex designer '' --no-designer-plugin)
- $(usex gles2 '--disable-feature=PyQt_Desktop_OpenGL' '')
+ $(usex gles2-only '--disable-feature=PyQt_Desktop_OpenGL' '')
$(pyqt_use_enable gui)
- $(pyqt_use_enable gui $(use gles2 && echo _QOpenGLFunctions_ES2 || echo _QOpenGLFunctions_{2_0,2_1,4_1_Core}))
+ $(pyqt_use_enable gui $(use gles2-only && echo _QOpenGLFunctions_ES2 || echo _QOpenGLFunctions_{2_0,2_1,4_1_Core}))
$(pyqt_use_enable help)
$(pyqt_use_enable location)
$(pyqt_use_enable multimedia QtMultimedia $(usex widgets QtMultimediaWidgets ''))
diff --git a/dev-python/PyQt5/PyQt5-5.14.1.ebuild b/dev-python/PyQt5/PyQt5-5.14.1-r1.ebuild
index 1a712c4cf85d..d8ef5f3a330b 100644
--- a/dev-python/PyQt5/PyQt5-5.14.1.ebuild
+++ b/dev-python/PyQt5/PyQt5-5.14.1-r1.ebuild
@@ -21,7 +21,7 @@ SLOT="0"
KEYWORDS="amd64 ~arm ~arm64 ~ppc ~ppc64 x86"
# TODO: QtNfc, QtRemoteObjects (Qt >= 5.12)
-IUSE="bluetooth dbus debug declarative designer examples gles2 gui help location multimedia
+IUSE="bluetooth dbus debug declarative designer examples gles2-only gui help location multimedia
network networkauth opengl positioning printsupport sensors serialport sql +ssl svg
testlib webchannel webkit websockets widgets x11extras xmlpatterns"
@@ -69,7 +69,7 @@ RDEPEND="
)
declarative? ( >=dev-qt/qtdeclarative-${QT_PV}[widgets?] )
designer? ( >=dev-qt/designer-${QT_PV} )
- gui? ( >=dev-qt/qtgui-${QT_PV}[gles2=] )
+ gui? ( >=dev-qt/qtgui-${QT_PV}[gles2-only=] )
help? ( >=dev-qt/qthelp-${QT_PV} )
location? ( >=dev-qt/qtlocation-${QT_PV} )
multimedia? ( >=dev-qt/qtmultimedia-${QT_PV}[widgets?] )
@@ -128,9 +128,9 @@ src_configure() {
$(usex declarative '' --no-qml-plugin)
$(pyqt_use_enable designer)
$(usex designer '' --no-designer-plugin)
- $(usex gles2 '--disable-feature=PyQt_Desktop_OpenGL' '')
+ $(usex gles2-only '--disable-feature=PyQt_Desktop_OpenGL' '')
$(pyqt_use_enable gui)
- $(pyqt_use_enable gui $(use gles2 && echo _QOpenGLFunctions_ES2 || echo _QOpenGLFunctions_{2_0,2_1,4_1_Core}))
+ $(pyqt_use_enable gui $(use gles2-only && echo _QOpenGLFunctions_ES2 || echo _QOpenGLFunctions_{2_0,2_1,4_1_Core}))
$(pyqt_use_enable help)
$(pyqt_use_enable location)
$(pyqt_use_enable multimedia QtMultimedia $(usex widgets QtMultimediaWidgets ''))
diff --git a/dev-python/PyQt5/metadata.xml b/dev-python/PyQt5/metadata.xml
index d337ce9c4697..fc69b98a7a4d 100644
--- a/dev-python/PyQt5/metadata.xml
+++ b/dev-python/PyQt5/metadata.xml
@@ -10,7 +10,6 @@
<flag name="dbus">Build bindings for the QtDBus module</flag>
<flag name="declarative">Build bindings for the QtQml/QtQuick modules and enable the qmlscene plugin</flag>
<flag name="designer">Build bindings for the QtDesigner module and enable the designer plugin</flag>
- <flag name="gles2">Use GLES 2.0 or later instead of full OpenGL</flag>
<flag name="gui">Build bindings for the QtGui module</flag>
<flag name="help">Build bindings for the QtHelp module</flag>
<flag name="location">Build bindings for the QtLocation module</flag>