summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-05 22:37:31 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-05 23:05:33 +0100
commitd3622ead279aa6020259d5d69dfd26e48ca14ea3 (patch)
tree63d909be32b51b87bdc4b514593ad5bdc75c86ba /dev-python/MechanicalSoup
parentdev-python/boto3: Bump to 1.16.49 (diff)
downloadgentoo-d3622ead279aa6020259d5d69dfd26e48ca14ea3.tar.gz
gentoo-d3622ead279aa6020259d5d69dfd26e48ca14ea3.tar.bz2
gentoo-d3622ead279aa6020259d5d69dfd26e48ca14ea3.zip
dev-python/MechanicalSoup: Bump to 1.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/MechanicalSoup')
-rw-r--r--dev-python/MechanicalSoup/Manifest1
-rw-r--r--dev-python/MechanicalSoup/MechanicalSoup-1.0.0.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/MechanicalSoup/Manifest b/dev-python/MechanicalSoup/Manifest
index 0e84d9339704..3c645248837a 100644
--- a/dev-python/MechanicalSoup/Manifest
+++ b/dev-python/MechanicalSoup/Manifest
@@ -1 +1,2 @@
DIST MechanicalSoup-0.12.0.tar.gz 44505 BLAKE2B 7c303f7ae4dea12157d5c845a4dcdc6923e76d3565debd88d2f43e2cfc29a503feb6accb969839a39b1c4071b029f53908a12902a5c4f175f0383da227224c55 SHA512 6cce80ea5a90e7f19f2b13749f6ee48222d973af66cb350ac867a554580b0d619defe5a93741e6ec8aa808c585a8c01703158c7484521ac069977388de8bb7e3
+DIST MechanicalSoup-1.0.0.tar.gz 47572 BLAKE2B eace6cc4eaf50f01f8a7816d4d87a9345676b6921c8fe46b3280ac83463b241b2e6175b91ee1a5f907635c07ee8cf66324cb2e7938736b81e9a4f849f9159548 SHA512 00e2c5220c065b517301d9381a9bc5019f6f75dc5951a5ab4427fd7939b296b6b33a20b8f8a7e82c6feed2c9100e3481f38a424d63065883d71a6927119ad88c
diff --git a/dev-python/MechanicalSoup/MechanicalSoup-1.0.0.ebuild b/dev-python/MechanicalSoup/MechanicalSoup-1.0.0.ebuild
new file mode 100644
index 000000000000..ef1df0c3a84c
--- /dev/null
+++ b/dev-python/MechanicalSoup/MechanicalSoup-1.0.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="A python library for automating interaction with websites"
+HOMEPAGE="https://pypi.org/project/MechanicalSoup/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+RDEPEND="
+ >=dev-python/beautifulsoup-4.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.4[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/requests-mock-1.3.0[${PYTHON_USEDEP}]
+ dev-python/pytest-httpbin[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs
+
+python_prepare_all() {
+ # Override pytest options to skip coverage and flake8
+ sed -i -e '/^addopts =/d' setup.cfg || die
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ if use examples; then
+ docompress -x "/usr/share/doc/${PF}/examples"
+ dodoc -r examples
+ fi
+ distutils-r1_python_install_all
+}