summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-03-05 05:55:56 +0100
committerMichał Górny <mgorny@gentoo.org>2024-03-05 06:18:25 +0100
commit3ca008093aeb06290112de142689b5054576527c (patch)
treea8f766599745d66fbe75193ea68738342f0af085 /dev-python/Faker
parentdev-python/ipyparallel: Remove wrong pytest restriction (diff)
downloadgentoo-3ca008093aeb06290112de142689b5054576527c.tar.gz
gentoo-3ca008093aeb06290112de142689b5054576527c.tar.bz2
gentoo-3ca008093aeb06290112de142689b5054576527c.zip
dev-python/Faker: Bump to 24.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/Faker')
-rw-r--r--dev-python/Faker/Faker-24.0.0.ebuild40
-rw-r--r--dev-python/Faker/Manifest1
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/Faker/Faker-24.0.0.ebuild b/dev-python/Faker/Faker-24.0.0.ebuild
new file mode 100644
index 000000000000..4a85c701f3c8
--- /dev/null
+++ b/dev-python/Faker/Faker-24.0.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A Python package that generates fake data for you"
+HOMEPAGE="
+ https://github.com/joke2k/faker/
+ https://pypi.org/project/Faker/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/python-dateutil-2.4.2[${PYTHON_USEDEP}]
+ !dev-ruby/faker
+"
+BDEPEND="
+ test? (
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP},tiff]
+ dev-python/validators[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=faker.contrib.pytest.plugin
+ epytest
+}
diff --git a/dev-python/Faker/Manifest b/dev-python/Faker/Manifest
index 974e50c8f5c0..fd4a609f652b 100644
--- a/dev-python/Faker/Manifest
+++ b/dev-python/Faker/Manifest
@@ -1,2 +1,3 @@
DIST Faker-23.2.1.tar.gz 1708603 BLAKE2B 94759727bb7feb520d51c3a52e50e01bad164cc3f262620d9f106f4746e68b298447d678dba7a5af9a80d0fdd7d9981f57ca50e27ab10671caec52c34e0442ee SHA512 1fefc84bed97e012c4e07117d62a6e0970e1be9d1c2b6f09db497b0d5ba66a2b2b0f3ba806926621d59dc0753a8b8c9caacefa15fbb23c755f110c5ef908975d
DIST Faker-23.3.0.tar.gz 1716346 BLAKE2B 21be02c45fdaeed398ce157b9874985791dff67784b60198323ffae8f8c3a3e82932ebc152893aed40efb5d73e1e775c52b364c62411b59e48ce3d897971ba92 SHA512 2bdcf86adae1eeee257ee24df140894451d13854afdde8794d08072b9b572e48fcacb74597f64da9f069e914db0f27c8f4e74d746a25bbee8421310749468b82
+DIST Faker-24.0.0.tar.gz 1716657 BLAKE2B 6dd4ff39e2d7ecd941a1c12c34894f092603f00331e147aa3056a3a15eb7a06c88c0000cf5a9fc1b754299bd5e3a707b7b95f7842c5eeb00dc2089f065bfca0c SHA512 cd764feb37863f98038d9b9da8c41967e9e8fc1fd250a92b3cea376610ecda3f90fd691297c824fe83845fc0bc0a8d859f96512ee2b6b720d4e12f2cd8d6c8d3