summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVladimir Pavljuchenkov (SpiderX) <spiderx@spiderx.dp.ua>2018-12-18 09:21:01 +0200
committerJoonas Niilola <juippis@gentoo.org>2021-02-01 15:22:48 +0200
commit755af4f2674d5d09a1ccf0d7b4a091a96a597dbb (patch)
tree7660884a74c8e23cf9ffb6fa24b34fa0dc7fec02 /dev-php/scrypt/scrypt-9999.ebuild
parentapp-admin/doctl: new ebuild (diff)
downloadgentoo-755af4f2674d5d09a1ccf0d7b4a091a96a597dbb.tar.gz
gentoo-755af4f2674d5d09a1ccf0d7b4a091a96a597dbb.tar.bz2
gentoo-755af4f2674d5d09a1ccf0d7b4a091a96a597dbb.zip
dev-php/scrypt: new ebuild
This is a PHP library providing a wrapper to Colin Percival's scrypt implementation. Scrypt is a key derivation function designed to be far more secure against hardware brute-force attacks than alternative functions such as PBKDF2 or bcrypt. Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Vladimir Pavljuchenkov <spiderx@spiderx.dp.ua> Closes: https://github.com/gentoo/gentoo/pull/10657 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-php/scrypt/scrypt-9999.ebuild')
-rw-r--r--dev-php/scrypt/scrypt-9999.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-php/scrypt/scrypt-9999.ebuild b/dev-php/scrypt/scrypt-9999.ebuild
new file mode 100644
index 000000000000..900385d5cf23
--- /dev/null
+++ b/dev-php/scrypt/scrypt-9999.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PHP_EXT_ECONF_ARGS="--enable-scrypt"
+USE_PHP="php7-3 php7-4 php8-0"
+EGIT_REPO_URI="https://github.com/DomBlack/php-scrypt.git"
+
+inherit git-r3 php-ext-pecl-r3
+
+DESCRIPTION="A PHP wrapper fo the scrypt hashing algorithm"
+SRC_URI=""
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+DEPEND="dev-util/re2c"