summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-07-14 09:01:22 +1200
committerKent Fredric <kentnl@gentoo.org>2020-07-14 09:01:43 +1200
commit51ddb1fc1cc2bfc81c30b31462d4a623a1ed473d (patch)
tree26ca0218140e2de50743706f7074be8b9b9af19b /dev-perl/DBIx-Migration
parentdev-python/readthedocs-sphinx-ext: arm64 stable (bug #731588) (diff)
downloadgentoo-51ddb1fc1cc2bfc81c30b31462d4a623a1ed473d.tar.gz
gentoo-51ddb1fc1cc2bfc81c30b31462d4a623a1ed473d.tar.bz2
gentoo-51ddb1fc1cc2bfc81c30b31462d4a623a1ed473d.zip
dev-perl/DBIx-Migration: -r bump for EAPI7
- EAPI7 - Unconditionally patch bad tests - Parallel tests Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl/DBIx-Migration')
-rw-r--r--dev-perl/DBIx-Migration/DBIx-Migration-0.70.0-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-perl/DBIx-Migration/DBIx-Migration-0.70.0-r1.ebuild b/dev-perl/DBIx-Migration/DBIx-Migration-0.70.0-r1.ebuild
new file mode 100644
index 000000000000..e4eaaba7ee0f
--- /dev/null
+++ b/dev-perl/DBIx-Migration/DBIx-Migration-0.70.0-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=DANIEL
+DIST_VERSION=0.07
+inherit perl-module
+
+DESCRIPTION="Seamless DB schema up- and downgrades"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-perl/File-Slurp
+ virtual/perl-File-Spec
+ dev-perl/DBI
+ dev-perl/Class-Accessor
+"
+DEPEND="
+ dev-perl/Module-Build
+"
+BDEPEND="${RDEPEND}
+ >=dev-perl/Module-Build-0.340.201
+ test? (
+ dev-perl/DBD-SQLite
+ )
+"
+PERL_RM_FILES=(
+ t/02pod.t
+ t/03podcoverage.t
+)