summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-10-03 20:29:16 +1300
committerKent Fredric <kentnl@gentoo.org>2017-10-03 20:30:03 +1300
commit3a948a110ad8e44beba6a6ae3edf67b8cca66981 (patch)
tree7ef610d6467cca0e578ed26ad9f28f7321ab076d /dev-perl/Cache-Memcached-Fast/Cache-Memcached-Fast-0.250.0.ebuild
parentsys-auth/libyubikey: Remove proxied maintainer (diff)
downloadgentoo-3a948a110ad8e44beba6a6ae3edf67b8cca66981.tar.gz
gentoo-3a948a110ad8e44beba6a6ae3edf67b8cca66981.tar.bz2
gentoo-3a948a110ad8e44beba6a6ae3edf67b8cca66981.zip
dev-perl/Cache-Memcached-Fast: Bump to version 0.250.0
- EAPI6 - Parallelize tests - Significantly expand test coverage by running a memcached test instance when testing - Fix building failures on Perl with -flto - Add USE="examples" Upstream: - Return undef on server errors - Prevent undefined values causing SEGV - Avoid superflouous evals in new() Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'dev-perl/Cache-Memcached-Fast/Cache-Memcached-Fast-0.250.0.ebuild')
-rw-r--r--dev-perl/Cache-Memcached-Fast/Cache-Memcached-Fast-0.250.0.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-perl/Cache-Memcached-Fast/Cache-Memcached-Fast-0.250.0.ebuild b/dev-perl/Cache-Memcached-Fast/Cache-Memcached-Fast-0.250.0.ebuild
new file mode 100644
index 000000000000..00091ed9e06f
--- /dev/null
+++ b/dev-perl/Cache-Memcached-Fast/Cache-Memcached-Fast-0.250.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=RAZ
+DIST_VERSION=0.25
+DIST_EXAMPLES=("script/*")
+inherit perl-module
+
+DESCRIPTION="Perl client for memcached, in C language"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+PATCHES=(
+ "${FILESDIR}/0.230.0-parallel-make.patch"
+ "${FILESDIR}/${P}-no-flto.patch"
+)
+RDEPEND="virtual/perl-Storable"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ net-misc/memcached
+ virtual/perl-Test-Simple
+ )
+"
+
+src_test() {
+ perl_rm_files t/pod-coverage.t t/pod.t
+
+ local memcached_opts=( -d -P "${T}/memcached.pid" -p 11211 -l 127.0.0.1 )
+ [[ ${EUID} == 0 ]] && memcached_opts+=( -u portage )
+ memcached "${memcached_opts[@]}" || die "Can't start memcached test server"
+
+ local exit_status
+ perl-module_src_test
+ exit_status=$?
+
+ kill "$(<"${T}/memcached.pid")"
+ return ${exit_status}
+}