summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-05-07 00:58:41 +1200
committerKent Fredric <kentnl@gentoo.org>2020-05-07 00:59:41 +1200
commit7819419086f49e840befcccde8bb07c87a0c0c29 (patch)
treefe07927eacd04857d44176831182ced32294456b /dev-perl/Business-ISSN/Business-ISSN-1.4.0.ebuild
parentsys-kernel/gentoo-sources: Linux patch 5.4.39 (diff)
downloadgentoo-7819419086f49e840befcccde8bb07c87a0c0c29.tar.gz
gentoo-7819419086f49e840befcccde8bb07c87a0c0c29.tar.bz2
gentoo-7819419086f49e840befcccde8bb07c87a0c0c29.zip
dev-perl/Business-ISSN: Bump to version 1.4.0
- EAPI7 Upstream: - Republished as previous version was accidentally removed from CPAN Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl/Business-ISSN/Business-ISSN-1.4.0.ebuild')
-rw-r--r--dev-perl/Business-ISSN/Business-ISSN-1.4.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-perl/Business-ISSN/Business-ISSN-1.4.0.ebuild b/dev-perl/Business-ISSN/Business-ISSN-1.4.0.ebuild
new file mode 100644
index 000000000000..22ed9f1ea5ca
--- /dev/null
+++ b/dev-perl/Business-ISSN/Business-ISSN-1.4.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=BDFOY
+DIST_VERSION=1.004
+inherit perl-module
+
+DESCRIPTION="Object and functions to work with International Standard Serial Numbers"
+LICENSE="Artistic-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ virtual/perl-Exporter
+"
+BDEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.640.0
+ virtual/perl-File-Spec
+ test? (
+ >=virtual/perl-Test-Simple-1.0.0
+ )
+"
+PERL_RM_FILES=(
+ "t/pod.t"
+ "t/pod_coverage.t"
+ "t/test_manifest"
+)
+PATCHES=(
+ "${FILESDIR}/${PN}-1.003-no-test-manifest.patch"
+)