summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2024-06-15 17:54:04 +0200
committerAlfredo Tupone <tupone@gentoo.org>2024-06-15 17:56:12 +0200
commita6c8e511be2cbd9fafb0ad45d8fc8089b088d7d2 (patch)
tree9538a3cf209cc3f8296fd753fa122273f6b8696d /dev-ml
parentdev-ml/textutils: add 0.17.0 (diff)
downloadgentoo-a6c8e511be2cbd9fafb0ad45d8fc8089b088d7d2.tar.gz
gentoo-a6c8e511be2cbd9fafb0ad45d8fc8089b088d7d2.tar.bz2
gentoo-a6c8e511be2cbd9fafb0ad45d8fc8089b088d7d2.zip
dev-ml/async: add 0.17.0
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/async/Manifest1
-rw-r--r--dev-ml/async/async-0.17.0.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-ml/async/Manifest b/dev-ml/async/Manifest
index a95b1ffaa0de..a1e5fe667741 100644
--- a/dev-ml/async/Manifest
+++ b/dev-ml/async/Manifest
@@ -1,3 +1,4 @@
DIST async-0.14.0.tar.gz 65025 BLAKE2B 39e2bef8df12a9733b9ff11ce1bba22b095f79532ff27999e617db5c145e57ab2e1f7f9435a5952312a84dd75b24d76fd4279c524be933e8ded5be7b00d6729a SHA512 3e57ea742ab28d008e1c0b39a6fc6d0ac3ca78b644f678f79b9ceb8d9acb23fcd45fed52f744906ab6d9b87955a27a8e4512043db45a7c836323d96433124b5c
DIST async-0.15.0.tar.gz 73958 BLAKE2B 696e175c9f67760da7723ec93670a7360ffb59bd192eb2632172c76018b9964cfa005878af9a00a6adc09db99ca7d1cfda2eb286a2e4337e3d4986cdabec5d78 SHA512 61d83e23394f819f02df0e4702a7cd6f82418da3a8ef62513d99fb7c9c1052fcf80f90f95ab41977aebf3b54e09a0595768131a9b61a5d28f47a920492bca0bb
DIST async-0.16.0.tar.gz 77022 BLAKE2B 0df5cc12772b013f780c1a8b146f65442d11dce61b762fe0aff3f45ef67190ab786e5149fa568156d31410def6bf62f8cfa6d943b40a4720f1d84f03883a5d3b SHA512 4668387de903654e9a73eb8218c9a70d5652d7e8ee255e0dfa6f86c4ba99260e9303499b97ff288c8184ba7e77c47964bfce2ce27bbbab4e4d59d2c9f6863505
+DIST async-0.17.0.tar.gz 86210 BLAKE2B fa8853a24d251bf5acaf6bff8a1dd115a7c80bf6650f886a70404bd9023495f381ab0cec723d50038e170ba6a0998e8c77066677e20a6047f18b5d44d73355ac SHA512 6947668d7b9be9716e5d1e629a74efbe6e22669083b7f97f605c62ea70eacab3b7573445e9cb028f7711ded294a07c6e9833f039496ede84958aa2e5794b270d
diff --git a/dev-ml/async/async-0.17.0.ebuild b/dev-ml/async/async-0.17.0.ebuild
new file mode 100644
index 000000000000..715381ce022b
--- /dev/null
+++ b/dev-ml/async/async-0.17.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Jane Street Capital's asynchronous execution library"
+HOMEPAGE="https://github.com/janestreet/async"
+SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64"
+IUSE="+ocamlopt"
+
+# Need qtest_lib, netkit_sockets
+# Unpackaged test deps
+RESTRICT="test"
+
+RDEPEND="
+ >=dev-lang/ocaml-5
+ dev-ml/async_kernel:${SLOT}[ocamlopt?]
+ dev-ml/async_log:${SLOT}[ocamlopt?]
+ dev-ml/async_rpc_kernel:${SLOT}[ocamlopt?]
+ dev-ml/async_unix:${SLOT}[ocamlopt?]
+ dev-ml/core:${SLOT}[ocamlopt?]
+ dev-ml/core_kernel:${SLOT}[ocamlopt?]
+ dev-ml/core_unix:${SLOT}[ocamlopt?]
+ dev-ml/ppx_jane:${SLOT}[ocamlopt?]
+ dev-ml/textutils:${SLOT}[ocamlopt?]
+"
+DEPEND="${RDEPEND}"
+BDEPEND=">=dev-ml/dune-3.11"