summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2022-12-22 08:43:59 +0100
committerAlfredo Tupone <tupone@gentoo.org>2022-12-22 08:45:17 +0100
commit30b7745ed174255ab0e2fb712927065df9e6f4f4 (patch)
treea435c840c9133c786cce1f84ca8dccc53dcee36b /dev-ml
parentmedia-plugins/imlib2_loaders: Stabilize 1.9.1 x86, #887201 (diff)
downloadgentoo-30b7745ed174255ab0e2fb712927065df9e6f4f4.tar.gz
gentoo-30b7745ed174255ab0e2fb712927065df9e6f4f4.tar.bz2
gentoo-30b7745ed174255ab0e2fb712927065df9e6f4f4.zip
dev-ml/ocamlnet: add hard dependency in Makefile
Closes: https://bugs.gentoo.org/887479 Closes: https://bugs.gentoo.org/887687 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ocamlnet/files/ocamlnet-4.1.9-unboundLexer.patch10
-rw-r--r--dev-ml/ocamlnet/ocamlnet-4.1.9.ebuild2
2 files changed, 12 insertions, 0 deletions
diff --git a/dev-ml/ocamlnet/files/ocamlnet-4.1.9-unboundLexer.patch b/dev-ml/ocamlnet/files/ocamlnet-4.1.9-unboundLexer.patch
new file mode 100644
index 000000000000..416df217c035
--- /dev/null
+++ b/dev-ml/ocamlnet/files/ocamlnet-4.1.9-unboundLexer.patch
@@ -0,0 +1,10 @@
+--- a/src/rpc-generator/Makefile 2022-12-22 08:32:49.839794123 +0100
++++ b/src/rpc-generator/Makefile 2022-12-22 08:34:48.185817182 +0100
+@@ -31,4 +31,7 @@
+ rpcgen-packlist:
+ echo $(BINDIR)/ocamlrpcgen >rpcgen-packlist
+
++main.cmo: lexer.cmo
++lexer.cmo: parser.cmo
++
+ include depend
diff --git a/dev-ml/ocamlnet/ocamlnet-4.1.9.ebuild b/dev-ml/ocamlnet/ocamlnet-4.1.9.ebuild
index 5eb163cf9132..6bd4d2437240 100644
--- a/dev-ml/ocamlnet/ocamlnet-4.1.9.ebuild
+++ b/dev-ml/ocamlnet/ocamlnet-4.1.9.ebuild
@@ -35,6 +35,8 @@ RDEPEND="
"
DEPEND="${RDEPEND}"
+PATCHES=( "${FILESDIR}"/${P}-unboundLexer.patch )
+
ocamlnet_use_with() {
if use $1; then
echo "-with-$2"