summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2023-12-29 23:34:28 +0100
committerAlfredo Tupone <tupone@gentoo.org>2023-12-29 23:34:28 +0100
commitdc835c2e41e9bae1c2567e811b6fab772bba8ae5 (patch)
treec19f48f2cd4b42cfbedc5758ca56288254ae2a09 /dev-ml/sexplib/sexplib-0.15.1-r2.ebuild
parentdev-ml/ppx_sexp_conv: add ocamlopt? deps (diff)
downloadgentoo-dc835c2e41e9bae1c2567e811b6fab772bba8ae5.tar.gz
gentoo-dc835c2e41e9bae1c2567e811b6fab772bba8ae5.tar.bz2
gentoo-dc835c2e41e9bae1c2567e811b6fab772bba8ae5.zip
dev-ml/sexplib: add ocamlopt? dep
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ml/sexplib/sexplib-0.15.1-r2.ebuild')
-rw-r--r--dev-ml/sexplib/sexplib-0.15.1-r2.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-ml/sexplib/sexplib-0.15.1-r2.ebuild b/dev-ml/sexplib/sexplib-0.15.1-r2.ebuild
new file mode 100644
index 000000000000..bd09e3007d8e
--- /dev/null
+++ b/dev-ml/sexplib/sexplib-0.15.1-r2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Library for automated conversion of OCaml-values to and from S-expressions"
+HOMEPAGE="https://github.com/janestreet/sexplib"
+SRC_URI="https://github.com/janestreet/sexplib/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="amd64 arm arm64 ~ppc ppc64 ~riscv x86"
+IUSE="+ocamlopt"
+
+RDEPEND="
+ dev-ml/parsexp:0/0.15[ocamlopt?]
+ dev-ml/base:0/0.15[ocamlopt?]
+ =dev-ml/sexplib0-0.15*:=[ocamlopt?]
+ dev-ml/num:=[ocamlopt?]
+"
+DEPEND="${RDEPEND}"