summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2022-09-20 19:57:27 +0200
committerAlfredo Tupone <tupone@gentoo.org>2022-09-20 19:57:27 +0200
commit2958fd6e3029daf53af53720cc85840d2374c6ec (patch)
tree3fc418b3d2639fae946314b052086a80c53842e1 /dev-ml/ocamlfuse
parentapp-text/paperwork: Fix compat w/ new Levenshtein pkg (diff)
downloadgentoo-2958fd6e3029daf53af53720cc85840d2374c6ec.tar.gz
gentoo-2958fd6e3029daf53af53720cc85840d2374c6ec.tar.bz2
gentoo-2958fd6e3029daf53af53720cc85840d2374c6ec.zip
dev-ml/ocamlfuse: add unistd include
Closes: https://bugs.gentoo.org/870685 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ml/ocamlfuse')
-rw-r--r--dev-ml/ocamlfuse/files/ocamlfuse-2.7.1_p7-unistd.patch10
-rw-r--r--dev-ml/ocamlfuse/ocamlfuse-2.7.1_p7-r1.ebuild2
2 files changed, 12 insertions, 0 deletions
diff --git a/dev-ml/ocamlfuse/files/ocamlfuse-2.7.1_p7-unistd.patch b/dev-ml/ocamlfuse/files/ocamlfuse-2.7.1_p7-unistd.patch
new file mode 100644
index 000000000000..b13f906a5ef3
--- /dev/null
+++ b/dev-ml/ocamlfuse/files/ocamlfuse-2.7.1_p7-unistd.patch
@@ -0,0 +1,10 @@
+--- a/lib/Unix_util_stubs.c 2022-09-20 19:53:44.445778566 +0200
++++ b/lib/Unix_util_stubs.c 2022-09-20 19:54:03.521504343 +0200
+@@ -24,6 +24,7 @@
+ vincenzo_ml@yahoo.it
+ */
+
++#include <unistd.h>
+ #include <stddef.h>
+ #include <string.h>
+ #include <errno.h>
diff --git a/dev-ml/ocamlfuse/ocamlfuse-2.7.1_p7-r1.ebuild b/dev-ml/ocamlfuse/ocamlfuse-2.7.1_p7-r1.ebuild
index fdf08ccbc300..63891abc2fe4 100644
--- a/dev-ml/ocamlfuse/ocamlfuse-2.7.1_p7-r1.ebuild
+++ b/dev-ml/ocamlfuse/ocamlfuse-2.7.1_p7-r1.ebuild
@@ -31,6 +31,8 @@ BDEPEND="
dev-ml/opam
"
+PATCHES=( "${FILESDIR}"/${P}-unistd.patch )
+
src_compile() {
tc-export CPP
dune_src_compile