summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn M. Harris Jr. <johnmh@johnmh.me>2024-10-13 16:43:22 -0700
committerYixun Lan <dlan@gentoo.org>2024-10-17 19:39:58 +0800
commitdf1e41598250dbfd64f33e22ab2b24cee398de36 (patch)
tree9d50dc82bca75ed1d813506a6778931be3acb753 /dev-libs
parentdev-libs/hyprlang: add 0.5.3 (diff)
downloadgentoo-df1e41598250dbfd64f33e22ab2b24cee398de36.tar.gz
gentoo-df1e41598250dbfd64f33e22ab2b24cee398de36.tar.bz2
gentoo-df1e41598250dbfd64f33e22ab2b24cee398de36.zip
dev-libs/hyprland-protocols: add 0.4.0
Signed-off-by: John M. Harris Jr. <johnmh@johnmh.me> Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/hyprland-protocols/Manifest1
-rw-r--r--dev-libs/hyprland-protocols/hyprland-protocols-0.4.0.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-libs/hyprland-protocols/Manifest b/dev-libs/hyprland-protocols/Manifest
index 57a0c446e1d5..2967b1a44da7 100644
--- a/dev-libs/hyprland-protocols/Manifest
+++ b/dev-libs/hyprland-protocols/Manifest
@@ -1 +1,2 @@
DIST hyprland-protocols-0.3.0.gh.tar.gz 7423 BLAKE2B 1ecc6625152e9bd530490d8321dcbe41396dd7306066f6cd6d97c22a0ebb2c914348b6829e8d5e210f07807a7df282a1cc63fa44a93bd08df22987850bd27a3a SHA512 15bb0c45eed1949d888d228c671139fefd48e32d634823ed8041a4901e15e73409b0fd368d4c1f6197bd6980e723b20303697ad46b1171330cfd27821118ba32
+DIST hyprland-protocols-0.4.0.gh.tar.gz 8131 BLAKE2B 3187849ed4e460a06a6c88919972f1a8989f6aa2dff24209da5697dddbfcfb82898babdc275246942a9b6e79f922a58c4139870b5c68fc2d28288400cedfb80e SHA512 cc32cae0840c49a7f128150be99b3584d5e5eb417a321ae7c917a859715e263c199001f73e7642348e2ae670ed4fffeecab9649144920d90999f46e9bfb8f938
diff --git a/dev-libs/hyprland-protocols/hyprland-protocols-0.4.0.ebuild b/dev-libs/hyprland-protocols/hyprland-protocols-0.4.0.ebuild
new file mode 100644
index 000000000000..f5179590cd2f
--- /dev/null
+++ b/dev-libs/hyprland-protocols/hyprland-protocols-0.4.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="Wayland protocol extensions for Hyprland"
+HOMEPAGE="https://github.com/hyprwm/hyprland-protocols"
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://github.com/hyprwm/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/hyprwm/${PN}/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+ KEYWORDS="~amd64 ~riscv"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+
+BDEPEND="
+ dev-util/wayland-scanner
+ virtual/pkgconfig
+"