summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViorel Munteanu <ceamac@gentoo.org>2023-09-14 19:41:02 +0300
committerViorel Munteanu <ceamac@gentoo.org>2023-09-14 19:43:27 +0300
commitcf191257a79d37fb55e450436fdbf5598c1b1fc5 (patch)
treef5a68ff7cd4cfa410612de41ea5b49461ca7194f /dev-libs/yyjson
parentdev-db/postgis: Support postgres-16 (diff)
downloadgentoo-cf191257a79d37fb55e450436fdbf5598c1b1fc5.tar.gz
gentoo-cf191257a79d37fb55e450436fdbf5598c1b1fc5.tar.bz2
gentoo-cf191257a79d37fb55e450436fdbf5598c1b1fc5.zip
dev-libs/yyjson: add 0.8.0
Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
Diffstat (limited to 'dev-libs/yyjson')
-rw-r--r--dev-libs/yyjson/Manifest1
-rw-r--r--dev-libs/yyjson/yyjson-0.8.0.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-libs/yyjson/Manifest b/dev-libs/yyjson/Manifest
index a81627194462..80ea8fc3fd84 100644
--- a/dev-libs/yyjson/Manifest
+++ b/dev-libs/yyjson/Manifest
@@ -1 +1,2 @@
DIST yyjson-0.7.0.tar.gz 1511395 BLAKE2B a088ecaf049b4fd5562a15759dfb67e5a1612ca848a658898bf7b9fe2e8bf7df1270d2a4fe477a92df8963065fb60ce5dbf69da5eb7fa1e282f821222329032d SHA512 91a14d2292cebc5d3eb0954511c1d27d6fa45f778febe73bac700acdbeba3bfc485db444d49cab903dc323eacdb74625059465e4a45a1eca5a1e397768f422f5
+DIST yyjson-0.8.0.tar.gz 1529369 BLAKE2B b76acfbc48a3520129c5ecffd61b5eb06a1a0103b09e31cf45ead6ddb9876c30c0d096e104bb73a57c128b42fa9b5dd7af700144d61dd51e2ac14f188e5e5195 SHA512 3872b46930fd0f4d659004a4d08cdb1c506ccc2bf2888f5ee50523929a2b72f9d8e72ee71dc958ebca630f1886858d4350521bffc18c300a27d25436833384a9
diff --git a/dev-libs/yyjson/yyjson-0.8.0.ebuild b/dev-libs/yyjson/yyjson-0.8.0.ebuild
new file mode 100644
index 000000000000..cf8762112498
--- /dev/null
+++ b/dev-libs/yyjson/yyjson-0.8.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Fast JSON library in C"
+HOMEPAGE="https://github.com/ibireme/yyjson https://ibireme.github.io/yyjson/doc/doxygen/html/"
+SRC_URI="https://github.com/ibireme/yyjson/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT test? ( BSD )"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+
+IUSE="doc test"
+
+RESTRICT="!test? ( test )"
+
+BDEPEND="doc? ( app-doc/doxygen )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.7.0-disable-werror.patch
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DYYJSON_BUILD_DOC=$(usex doc)
+ -DYYJSON_BUILD_TESTS=$(usex test)
+ -DYYJSON_ENABLE_VALGRIND=$(usex test)
+ )
+
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+
+ use doc && dodoc -r "${BUILD_DIR}"/doxygen/html
+}