summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-11-27 11:04:53 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2021-11-27 12:07:51 +0100
commitdb68d18893d159debe758f0896a1633f9fe9feeb (patch)
treee2303d895a2ae22640591d62bafa12d03bf22e1f /dev-libs/rinutils/rinutils-0.10.0.ebuild
parentkde-frameworks/ktexteditor: Drop 5.88.0 (r0) (diff)
downloadgentoo-db68d18893d159debe758f0896a1633f9fe9feeb.tar.gz
gentoo-db68d18893d159debe758f0896a1633f9fe9feeb.tar.bz2
gentoo-db68d18893d159debe758f0896a1633f9fe9feeb.zip
dev-libs/rinutils: 0.10.0 version bump
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-libs/rinutils/rinutils-0.10.0.ebuild')
-rw-r--r--dev-libs/rinutils/rinutils-0.10.0.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-libs/rinutils/rinutils-0.10.0.ebuild b/dev-libs/rinutils/rinutils-0.10.0.ebuild
new file mode 100644
index 000000000000..fc60f8875451
--- /dev/null
+++ b/dev-libs/rinutils/rinutils-0.10.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Set of C headers containing macros and static functions"
+HOMEPAGE="https://www.shlomifish.org/open-source/projects/ https://github.com/shlomif/rinutils"
+SRC_URI="https://github.com/shlomif/${PN}/releases/download/${PV}/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+
+src_configure() {
+ local mycmakeargs=(
+ -DDISABLE_APPLYING_RPATH=OFF
+ -DWITH_TEST_SUITE=OFF # tests require perl
+ )
+
+ cmake_src_configure
+}