summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2021-08-09 17:17:32 +0300
committerJoonas Niilola <juippis@gentoo.org>2021-08-09 17:25:24 +0300
commit09692b16b174e7f3952afe1bda98622e72a45b4e (patch)
tree865a57a84cf42dce3dc5bfcc4339093db95ec407 /dev-libs/raft
parentdev-libs/dqlite: add 1.9.0 (diff)
downloadgentoo-09692b16b174e7f3952afe1bda98622e72a45b4e.tar.gz
gentoo-09692b16b174e7f3952afe1bda98622e72a45b4e.tar.bz2
gentoo-09692b16b174e7f3952afe1bda98622e72a45b4e.zip
dev-libs/raft: add 0.11.2
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-libs/raft')
-rw-r--r--dev-libs/raft/Manifest1
-rw-r--r--dev-libs/raft/raft-0.11.2.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-libs/raft/Manifest b/dev-libs/raft/Manifest
index ceff883b0aad..8fdb14ce642a 100644
--- a/dev-libs/raft/Manifest
+++ b/dev-libs/raft/Manifest
@@ -1 +1,2 @@
DIST raft-0.11.1.tar.gz 324285 BLAKE2B 10e62a392bdbb98f262068ad2bcfbcd24488918fbb7d4c3b13101c3d771ff8b9d592bad31bfe69cfcb4d6e9c93e1d38da24d11a3167d37208906af4e354c9280 SHA512 5afbf0f7e325ed242c5a37a39038818395c1b39184e2440bf89db6662dee73b9abaa8fac0efc28dbc3478267aa66fd94e908e320a061fb5b343735e111dbea86
+DIST raft-0.11.2.tar.gz 325098 BLAKE2B d9366547440b431edec75a22bca3a50bb6d714b5d950c061723f0585c5ad33704d23c32f2e325dc566ebeab71e15e10f07932c854657837e190901b52c9b4950 SHA512 8be47270cf3b888ff6adeeec2480ccd5065b45c3c546da089cbb326cf429f0bcd4396001e20fbf52587c00d5757337812c834ec5064fafa4815a978a7cf0c35f
diff --git a/dev-libs/raft/raft-0.11.2.ebuild b/dev-libs/raft/raft-0.11.2.ebuild
new file mode 100644
index 000000000000..38fd31b339b1
--- /dev/null
+++ b/dev-libs/raft/raft-0.11.2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="C implementation of the Raft consensus protocol"
+HOMEPAGE="https://github.com/canonical/raft"
+SRC_URI="https://github.com/canonical/raft/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3-with-linking-exception"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+IUSE="lz4 test zfs"
+RESTRICT="!test? ( test )"
+
+DEPEND="dev-libs/libuv
+ lz4? ( app-arch/lz4 )"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/raft-0.9.25-Always-skip-init-oom-test.patch
+ "${FILESDIR}"/raft-0.10.0-toggle-zfs.patch
+ )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --enable-uv
+
+ --disable-benchmark
+ --disable-debug
+ --disable-example
+ --disable-sanitize
+ --disable-static
+
+ $(use_enable lz4)
+ $(use_enable test fixture)
+
+ $(use_with zfs)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}