summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorbrahmajit das <listout@protonmail.com>2022-08-16 21:55:49 +0530
committerSam James <sam@gentoo.org>2022-08-16 17:38:11 +0100
commit7864d3d2f3e2a7f87341328afc4074f0ffd113b7 (patch)
treee66651b15318a43855d7aa9160ea719e70a52ac3 /dev-libs/libtracefs
parentdev-libs/libgpiod: warn only for missing GPIO_CDEV_V1 (diff)
downloadgentoo-7864d3d2f3e2a7f87341328afc4074f0ffd113b7.tar.gz
gentoo-7864d3d2f3e2a7f87341328afc4074f0ffd113b7.tar.bz2
gentoo-7864d3d2f3e2a7f87341328afc4074f0ffd113b7.zip
dev-libs/libtracefs: Fix pthread_mutex_t unknown type on musl
On musl it is necessary to include pthread header else the compiler cannot identify pthread_mutex_t as a known type Closes: https://bugs.gentoo.org/855893 Signed-off-by: brahmajit das <listout@protonmail.com> Closes: https://github.com/gentoo/gentoo/pull/26882 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/libtracefs')
-rw-r--r--dev-libs/libtracefs/files/libtracefs-1.3.1-musl-pthread.patch16
-rw-r--r--dev-libs/libtracefs/libtracefs-1.3.1.ebuild4
2 files changed, 20 insertions, 0 deletions
diff --git a/dev-libs/libtracefs/files/libtracefs-1.3.1-musl-pthread.patch b/dev-libs/libtracefs/files/libtracefs-1.3.1-musl-pthread.patch
new file mode 100644
index 000000000000..0f909111150d
--- /dev/null
+++ b/dev-libs/libtracefs/files/libtracefs-1.3.1-musl-pthread.patch
@@ -0,0 +1,16 @@
+# On musl it is necessary to include pthread header else the compiler cannot
+# identify pthread_mutex_t as a known type
+# Closes: https://bugs.gentoo.org/855893
+diff --git a/include/tracefs-local.h b/include/tracefs-local.h
+index 926fd02..779e853 100644
+--- a/include/tracefs-local.h
++++ b/include/tracefs-local.h
+@@ -6,6 +6,8 @@
+ #ifndef _TRACE_FS_LOCAL_H
+ #define _TRACE_FS_LOCAL_H
+
++#include <pthread.h>
++
+ #define __hidden __attribute__((visibility ("hidden")))
+ #define __weak __attribute__((weak))
+
diff --git a/dev-libs/libtracefs/libtracefs-1.3.1.ebuild b/dev-libs/libtracefs/libtracefs-1.3.1.ebuild
index ae5b3a5331b9..d5ffcefc4d9b 100644
--- a/dev-libs/libtracefs/libtracefs-1.3.1.ebuild
+++ b/dev-libs/libtracefs/libtracefs-1.3.1.ebuild
@@ -28,6 +28,10 @@ BDEPEND="
doc? ( app-text/xmlto app-text/asciidoc )
"
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.3.1-musl-pthread.patch
+)
+
src_configure() {
EMAKE_FLAGS=(
"prefix=${EPREFIX}/usr"