summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-03-11 00:18:27 -0400
committerSam James <sam@gentoo.org>2024-03-11 14:22:52 +0000
commit76e4b9ae922159884be652aed7899371396e23bc (patch)
treebf81901b01a4a2966dfb88cae9904ba6b987fa1b /dev-libs/igraph
parentdev-libs/igraph: mark as LTO-unsafe, strict-aliasing unsafe (diff)
downloadgentoo-76e4b9ae922159884be652aed7899371396e23bc.tar.gz
gentoo-76e4b9ae922159884be652aed7899371396e23bc.tar.bz2
gentoo-76e4b9ae922159884be652aed7899371396e23bc.zip
dev-libs/igraph: drop old
This old version has been superseded with an -r1 since December. There's no excuse for anyone to still be using a buggy revision within a version. Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/igraph')
-rw-r--r--dev-libs/igraph/igraph-0.10.4.ebuild48
1 files changed, 0 insertions, 48 deletions
diff --git a/dev-libs/igraph/igraph-0.10.4.ebuild b/dev-libs/igraph/igraph-0.10.4.ebuild
deleted file mode 100644
index bdefdfb07f82..000000000000
--- a/dev-libs/igraph/igraph-0.10.4.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake
-
-DESCRIPTION="Creating and manipulating undirected and directed graphs"
-HOMEPAGE="https://igraph.org/"
-SRC_URI="https://github.com/igraph/igraph/releases/download/${PV}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0/0"
-KEYWORDS="amd64 x86"
-
-IUSE="debug test threads"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-libs/gmp:0=
- dev-libs/libxml2
- sci-libs/arpack
- sci-mathematics/glpk:=
- virtual/blas
- virtual/lapack"
-DEPEND="${RDEPEND}"
-
-src_configure() {
- local mycmakeargs=(
- -DUSE_CCACHE=OFF
- -DIGRAPH_GLPK_SUPPORT=ON
- -DIGRAPH_GRAPHML_SUPPORT=ON
- -DIGRAPH_USE_INTERNAL_ARPACK=OFF
- -DIGRAPH_USE_INTERNAL_BLAS=OFF
- -DIGRAPH_USE_INTERNAL_GLPK=OFF
- -DIGRAPH_USE_INTERNAL_GMP=OFF
- -DIGRAPH_USE_INTERNAL_LAPACK=OFF
- # Not packaged in ::gentoo atm
- -DIGRAPH_USE_INTERNAL_PLFIT=ON
- -DIGRAPH_ENABLE_TLS=$(usex threads)
- -DBUILD_TESTING=$(usex test)
- )
- cmake_src_configure
-}
-
-src_test() {
- cmake_build check
-}