summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/bitset
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/bitset')
-rw-r--r--dev-libs/bitset/Manifest2
-rw-r--r--dev-libs/bitset/bitset-2.8.3.ebuild33
-rw-r--r--dev-libs/bitset/bitset-2.8.4-r1.ebuild36
-rw-r--r--dev-libs/bitset/metadata.xml22
4 files changed, 93 insertions, 0 deletions
diff --git a/dev-libs/bitset/Manifest b/dev-libs/bitset/Manifest
new file mode 100644
index 000000000000..dfd7a8068373
--- /dev/null
+++ b/dev-libs/bitset/Manifest
@@ -0,0 +1,2 @@
+DIST bitset-2.8.3.tar.gz 36787 SHA256 87d9cb74405c4b496ba1bcb334afd60e15be0a17102b0e722337a6604f2e8469 SHA512 7b451139ee9db0b581e552d09f03809185e64f3b1190d887ba58478c4dc10a1ecc687d69cb42045e3c01ad9d065e12aa4f31d14068d7df9f6a8f284344d5b51c WHIRLPOOL d814d155c700817c636047d437c219d436fbcb2492294ee347f48368740866113318b278bf63094f84067f62dab6334b9f2a9607162f106815e013d96240b6e6
+DIST bitset-2.8.4.tar.gz 37040 SHA256 7e3a8d7e550ed24f646a3264c7efeb0b267f5f2d0f3177952b2ce5f6866e57b7 SHA512 709c4f064416b22ae37fc9659a9eb74007fff5ce12eb998c386a268427a012238258bbd0f019682a5172a98b7b2a476fd60017bf34e199159e838b254b48ffe7 WHIRLPOOL 2ed96fb305a8e88bff695b419dc73ecb64ebbdf5944d869a4bd3216ac77a88ede4dd646a6a5f64dc7e6bb77903acfc46e64d67359cc58151df288b86043e812c
diff --git a/dev-libs/bitset/bitset-2.8.3.ebuild b/dev-libs/bitset/bitset-2.8.3.ebuild
new file mode 100644
index 000000000000..b3168ecce2d6
--- /dev/null
+++ b/dev-libs/bitset/bitset-2.8.3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+AUTOTOOLS_AUTORECONF=1
+inherit autotools-utils
+
+DESCRIPTION="A compressed bitset with supporting data structures and algorithms"
+HOMEPAGE="http://github.com/chriso/bitset"
+SRC_URI="https://github.com/chriso/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE="jemalloc static-libs tcmalloc"
+KEYWORDS="amd64 x86"
+
+RDEPEND="tcmalloc? ( dev-util/google-perftools[-minimal] )
+ jemalloc? ( >=dev-libs/jemalloc-3.2 )"
+DEPEND="${RDEPEND}"
+
+REQUIRED_USE="?? ( jemalloc tcmalloc )"
+
+DOCS=( README.md )
+
+src_configure() {
+ local myeconfargs=(
+ $(use_with jemalloc) \
+ $(use_with tcmalloc)
+ )
+ autotools-utils_src_configure
+}
diff --git a/dev-libs/bitset/bitset-2.8.4-r1.ebuild b/dev-libs/bitset/bitset-2.8.4-r1.ebuild
new file mode 100644
index 000000000000..b353fdd918c5
--- /dev/null
+++ b/dev-libs/bitset/bitset-2.8.4-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+AUTOTOOLS_AUTORECONF=1
+inherit autotools-utils
+
+DESCRIPTION="A compressed bitset with supporting data structures and algorithms"
+HOMEPAGE="http://github.com/chriso/bitset"
+SRC_URI="https://github.com/chriso/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE="jemalloc static-libs tcmalloc"
+KEYWORDS="amd64 ~arm x86"
+
+RDEPEND="tcmalloc? ( dev-util/google-perftools:= )
+ jemalloc? ( >=dev-libs/jemalloc-3.2 )"
+DEPEND="${RDEPEND}"
+
+REQUIRED_USE="?? ( jemalloc tcmalloc )"
+
+DOCS=( README.md )
+
+src_configure() {
+ local tcmalloc_lib_name='tcmalloc'
+ has_version dev-util/google-perftools[minimal] && tcmalloc_lib_name='tcmalloc_minimal'
+ local myeconfargs=(
+ $(use_with jemalloc) \
+ $(use_with tcmalloc) \
+ $(use_with tcmalloc tcmalloc-lib "${tcmalloc_lib_name}")
+ )
+ autotools-utils_src_configure
+}
diff --git a/dev-libs/bitset/metadata.xml b/dev-libs/bitset/metadata.xml
new file mode 100644
index 000000000000..f6d8c23e83d0
--- /dev/null
+++ b/dev-libs/bitset/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>bugs@bergstroem.nu</email>
+ <name>Johan Bergström</name>
+ <description>Maintainer. Assign bugs to him</description>
+ </maintainer>
+ <maintainer>
+ <email>pinkbyte@gentoo.org</email>
+ <name>Sergey Popov</name>
+ <description>Proxy maintainer. CC him on bugs</description>
+ </maintainer>
+ <use>
+ <flag name="jemalloc">Use <pkg>dev-libs/jemalloc</pkg> for allocations</flag>
+ <flag name="tcmalloc">Use tcmalloc from <pkg>dev-util/google-perftools</pkg> for allocations</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">chriso/bitset</remote-id>
+ </upstream>
+</pkgmetadata>