summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-07-15 09:58:05 +0200
committerDavid Seifert <soap@gentoo.org>2022-07-15 09:58:05 +0200
commit742917f8c621f168617e55d17722fa8d7521c562 (patch)
tree46cadb9cad22c343b7364095b610b61a37239b7f /dev-libs/OpenNI2
parentmedia-video/transcode: altivec -> cpu_flags_ppc_altivec (diff)
downloadgentoo-742917f8c621f168617e55d17722fa8d7521c562.tar.gz
gentoo-742917f8c621f168617e55d17722fa8d7521c562.tar.bz2
gentoo-742917f8c621f168617e55d17722fa8d7521c562.zip
dev-libs/OpenNI2: neon -> cpu_flags_arm_neon
Closes: https://bugs.gentoo.org/694070 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-libs/OpenNI2')
-rw-r--r--dev-libs/OpenNI2/OpenNI2-2.2_beta2-r1.ebuild8
-rw-r--r--dev-libs/OpenNI2/OpenNI2-9999.ebuild10
2 files changed, 9 insertions, 9 deletions
diff --git a/dev-libs/OpenNI2/OpenNI2-2.2_beta2-r1.ebuild b/dev-libs/OpenNI2/OpenNI2-2.2_beta2-r1.ebuild
index a74f713947b0..13ddc4a27916 100644
--- a/dev-libs/OpenNI2/OpenNI2-2.2_beta2-r1.ebuild
+++ b/dev-libs/OpenNI2/OpenNI2-2.2_beta2-r1.ebuild
@@ -9,7 +9,7 @@ if [ "${PV#9999}" != "${PV}" ] ; then
EGIT_REPO_URI="https://github.com/occipital/openni2"
fi
-inherit ${SCM} toolchain-funcs multilib java-pkg-opt-2 flag-o-matic
+inherit ${SCM} toolchain-funcs java-pkg-opt-2
if [ "${PV#9999}" != "${PV}" ] ; then
SRC_URI=""
@@ -23,12 +23,12 @@ DESCRIPTION="OpenNI2 SDK"
HOMEPAGE="https://structure.io/openni"
LICENSE="Apache-2.0"
SLOT="0"
-IUSE="doc java neon opengl static-libs"
+IUSE="cpu_flags_arm_neon doc java opengl static-libs"
RDEPEND="
+ media-libs/libjpeg-turbo:=
virtual/libusb:1
virtual/libudev
- virtual/jpeg:0
opengl? ( media-libs/freeglut )
java? ( virtual/jre:1.8 )
"
@@ -54,7 +54,7 @@ src_prepare() {
}
src_compile() {
- use neon && export CFLAGS="${CFLAGS} -DXN_NEON"
+ use cpu_flags_arm_neon && export CFLAGS="${CFLAGS} -DXN_NEON"
emake \
CC="$(tc-getCC)" \
CXX="$(tc-getCXX)" \
diff --git a/dev-libs/OpenNI2/OpenNI2-9999.ebuild b/dev-libs/OpenNI2/OpenNI2-9999.ebuild
index 210a3efeea3a..ffd87acd6445 100644
--- a/dev-libs/OpenNI2/OpenNI2-9999.ebuild
+++ b/dev-libs/OpenNI2/OpenNI2-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -9,7 +9,7 @@ if [ "${PV#9999}" != "${PV}" ] ; then
EGIT_REPO_URI="https://github.com/occipital/openni2"
fi
-inherit ${SCM} toolchain-funcs multilib java-pkg-opt-2 flag-o-matic
+inherit ${SCM} toolchain-funcs java-pkg-opt-2
if [ "${PV#9999}" != "${PV}" ] ; then
SRC_URI=""
@@ -23,12 +23,12 @@ DESCRIPTION="OpenNI2 SDK"
HOMEPAGE="https://structure.io/openni"
LICENSE="Apache-2.0"
SLOT="0"
-IUSE="doc java neon opengl static-libs"
+IUSE="cpu_flags_arm_neon doc java opengl static-libs"
RDEPEND="
+ media-libs/libjpeg-turbo:=
virtual/libusb:1
virtual/libudev
- virtual/jpeg:0
opengl? ( media-libs/freeglut )
java? ( virtual/jre:1.8 )
"
@@ -52,7 +52,7 @@ src_prepare() {
}
src_compile() {
- use neon && export CFLAGS="${CFLAGS} -DXN_NEON"
+ use cpu_flags_arm_neon && export CFLAGS="${CFLAGS} -DXN_NEON"
emake \
CC="$(tc-getCC)" \
CXX="$(tc-getCXX)" \