summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2020-11-28 13:42:47 -0800
committerPatrick McLean <chutzpah@gentoo.org>2020-11-28 13:43:02 -0800
commit81041b3c67c62a14f29deb71cfc3f40aeff242fb (patch)
treebbb58600193663e7cdcacfaea022ae177426a66c /dev-lang
parentdev-python/python-docs: Remove old (diff)
downloadgentoo-81041b3c67c62a14f29deb71cfc3f40aeff242fb.tar.gz
gentoo-81041b3c67c62a14f29deb71cfc3f40aeff242fb.tar.bz2
gentoo-81041b3c67c62a14f29deb71cfc3f40aeff242fb.zip
dev-lang/jsonnet-0.17.0-r1: Fix regressions in last bump (bug #757312)
Made a mistake and started from the wrong ebuild when bumping. Closes: https://bugs.gentoo.org/757312 Package-Manager: Portage-3.0.10, Repoman-3.0.2 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/jsonnet/jsonnet-0.17.0-r1.ebuild (renamed from dev-lang/jsonnet/jsonnet-0.17.0.ebuild)27
1 files changed, 17 insertions, 10 deletions
diff --git a/dev-lang/jsonnet/jsonnet-0.17.0.ebuild b/dev-lang/jsonnet/jsonnet-0.17.0-r1.ebuild
index 67a0000cab80..3faabad2b33b 100644
--- a/dev-lang/jsonnet/jsonnet-0.17.0.ebuild
+++ b/dev-lang/jsonnet/jsonnet-0.17.0-r1.ebuild
@@ -4,14 +4,14 @@
EAPI=7
DISTUTILS_OPTIONAL=1
-PYTHON_COMPAT=( python3_{6..9} )
+PYTHON_COMPAT=( pypy3 python3_{6..9} )
inherit toolchain-funcs flag-o-matic distutils-r1
DESCRIPTION="A data templating language for app and tool developers "
HOMEPAGE="https://jsonnet.org/"
SRC_URI="https://github.com/google/jsonnet/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-IUSE="custom-optimization python"
+IUSE="custom-optimization doc examples python"
LICENSE="Apache-2.0"
SLOT="0"
@@ -34,6 +34,8 @@ REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
PATCHES=(
"${FILESDIR}/jsonnet-0.14.0-makefile.patch"
"${FILESDIR}/jsonnet-0.12.1-dont-call-make-from-setuppy.patch"
+ "${FILESDIR}/jsonnet-0.16.0-libdir.patch"
+ "${FILESDIR}/jsonnet-0.16.0-cp-var.patch"
)
distutils_enable_tests unittest
@@ -45,15 +47,12 @@ src_prepare() {
src_configure() {
use custom-optimization || replace-flags '-O*' -O3
+ tc-export CC CXX
default
}
src_compile() {
- emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" \
- jsonnet \
- libjsonnet.so \
- libjsonnet++.so
-
+ emake bins libs
use python && distutils-r1_src_compile
}
@@ -68,8 +67,16 @@ python_test() {
}
src_install() {
- dolib.so libjsonnet*.so
- dobin jsonnet
-
+ emake PREFIX="${EPREFIX}/usr" DESTDIR="${D}" \
+ CP="cp -d" LIBDIR="$(get_libdir)" install
use python && distutils-r1_src_install
+ if use doc; then
+ find doc -name '.gitignore' -delete || die
+ docinto html
+ dodoc -r doc/.
+ fi
+ if use examples; then
+ docinto examples
+ dodoc -r examples/.
+ fi
}