summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz@gentoo.org>2024-09-09 00:20:48 -0400
committerEli Schwartz <eschwartz@gentoo.org>2024-09-09 21:04:12 -0400
commit698e17aad2e95f56c53fc3139f45c03c33126edb (patch)
tree99bdeb0a1d295e55690ad2d63a83c7128e2be521 /dev-lang/mlton
parentsci-mathematics/twelf: mark as LTO-unsafe (diff)
downloadgentoo-698e17aad2e95f56c53fc3139f45c03c33126edb.tar.gz
gentoo-698e17aad2e95f56c53fc3139f45c03c33126edb.tar.bz2
gentoo-698e17aad2e95f56c53fc3139f45c03c33126edb.zip
dev-lang/mlton: mark as LTO-unsafe
It does something to mess with twelf's codegen. Assume it is too flaky to handle LTO. Bug: https://bugs.gentoo.org/863266 Signed-off-by: Eli Schwartz <eschwartz@gentoo.org>
Diffstat (limited to 'dev-lang/mlton')
-rw-r--r--dev-lang/mlton/mlton-20180207.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/dev-lang/mlton/mlton-20180207.ebuild b/dev-lang/mlton/mlton-20180207.ebuild
index 22cd719e8d45..44e66eaa657c 100644
--- a/dev-lang/mlton/mlton-20180207.ebuild
+++ b/dev-lang/mlton/mlton-20180207.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit check-reqs multibuild pax-utils
+inherit check-reqs flag-o-matic multibuild pax-utils
DESCRIPTION="Standard ML optimizing compiler and libraries"
BASE_URI="https://downloads.sourceforge.net/${PN}"
@@ -172,6 +172,10 @@ src_prepare() {
}
mlton_src_compile() {
+ # produces invalid codegen for twelf
+ # https://bugs.gentoo.org/863266
+ filter-lto
+
if [[ ${MULTIBUILD_VARIANT} == $(mlton_bootstrap_variant) ]]; then
emake -j1 \
"bootstrap-smlnj" \