summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmy Liffey <amynka@gentoo.org>2019-07-14 20:46:01 +0200
committerAmy Liffey <amynka@gentoo.org>2019-07-14 20:50:46 +0200
commita5e00cc560b2712ebce407eb1cb915eaa6c6788e (patch)
tree5ae79c4ffcca285536e3ee8ebf9ce1f7e1753c21 /dev-lang/lazarus
parentwww-client/surfraw: Old (diff)
downloadgentoo-a5e00cc560b2712ebce407eb1cb915eaa6c6788e.tar.gz
gentoo-a5e00cc560b2712ebce407eb1cb915eaa6c6788e.tar.bz2
gentoo-a5e00cc560b2712ebce407eb1cb915eaa6c6788e.zip
dev-lang/lazarus: version bump 2.0.2
Closes: https://bugs.gentoo.org/683974 Signed-off-by: Amy Liffey <amynka@gentoo.org> Package-Manager: Portage-2.3.66, Repoman-2.3.11
Diffstat (limited to 'dev-lang/lazarus')
-rw-r--r--dev-lang/lazarus/Manifest2
-rw-r--r--dev-lang/lazarus/lazarus-2.0.2.ebuild106
2 files changed, 108 insertions, 0 deletions
diff --git a/dev-lang/lazarus/Manifest b/dev-lang/lazarus/Manifest
index b69b39a19b0b..98fecb9a52ee 100644
--- a/dev-lang/lazarus/Manifest
+++ b/dev-lang/lazarus/Manifest
@@ -2,3 +2,5 @@ DIST lazarus-1.0.12-0.tar.gz 47687878 BLAKE2B 7a230f8ad433fefd514d8fca128e1ad127
DIST lazarus-1.6.4-0.tar.gz 57180961 BLAKE2B 930beda6ad04999e749fe4b76a64ab00b0138c18b0f3aea0cbac089ecb3f419aa4165d06757d6ee2d3c6e43401f2be5e154947d07f892a6bc5f4bb8831bad62d SHA512 d7d498483ef9e1eebd0d8ca2325d1984cb1297837ebe2f9547e67f26fc049c2168e2feeac739b8403c08a8251040e9161c962d25951545384ffbdbb076fda2aa
DIST lazarus-1.8.4-python.tar.gz 1060859 BLAKE2B 4d6f7dc275aacd0f70d9f7c85aba99a7722b02165a5bf287bfeed46f28e3b36c5abeac19bd7c6555250102dce169f7c9c213b634ce1b634c24dadc84171aed10 SHA512 f244b4e86410fdb2ffe8ccba7fcb51c270286172b6102f757118827cac3b652210a625d65dd6c017c1992983527792ed64334291ab0e0b824f187316452c56b5
DIST lazarus-1.8.4.tar.gz 63130653 BLAKE2B f9b2ba9971f1a9a9c3b8d2004bd3516c12db5384bb6243ef275c2fc0d458634fba0c1c23e7ecd5c160c1204d6cc2b4ebc340ce8bb5cfdd9c531f8c36ae59d1e2 SHA512 82cdc3c32dddf8e67c0bed9292a9a924227bab50f22ca479f5e98ecccbf60dd66c7f886ecb8e2979d9d8fccc3d25462ee8c55fcab085aa4194b4704660e0b95d
+DIST lazarus-2.0.2-python.tar.gz 1060859 BLAKE2B 4d6f7dc275aacd0f70d9f7c85aba99a7722b02165a5bf287bfeed46f28e3b36c5abeac19bd7c6555250102dce169f7c9c213b634ce1b634c24dadc84171aed10 SHA512 f244b4e86410fdb2ffe8ccba7fcb51c270286172b6102f757118827cac3b652210a625d65dd6c017c1992983527792ed64334291ab0e0b824f187316452c56b5
+DIST lazarus-2.0.2.tar.gz 67092332 BLAKE2B 12fdca5b0d7c8bcad4f1c6a70c2ebb1d0974b0884cf89135be069744f01527fcd5b2a4b4c898cb500519ec3518025da453087954722cab43a60c1cdb164371d4 SHA512 0d2bf26afa3128104181fbe57b1adeaba3bb589b0a3b72598507825a3f08201d4480c6cff510a6f866dca4d49417fac3a2f68ca7e58fabe4f4e3bad97323c071
diff --git a/dev-lang/lazarus/lazarus-2.0.2.ebuild b/dev-lang/lazarus/lazarus-2.0.2.ebuild
new file mode 100644
index 000000000000..8724ffdb8bac
--- /dev/null
+++ b/dev-lang/lazarus/lazarus-2.0.2.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop
+
+FPCVER="3.0.4"
+PYTHON_HASH="586eec1a5ea609ef9df2bf586be06825d9fbd50f"
+
+DESCRIPTION="Lazarus IDE is a feature rich visual programming environment emulating Delphi"
+HOMEPAGE="https://www.lazarus-ide.org/"
+SRC_URI="
+ python? ( https://github.com/Alexey-T/Python-for-Lazarus/archive/${PYTHON_HASH}.tar.gz ->\
+ ${P}-python.tar.gz )
+ https://sourceforge.net/projects/${PN}/files/Lazarus%20Zip%20_%20GZip/Lazarus%20${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1-with-linking-exception"
+SLOT="0" # Note: Slotting Lazarus needs slotting fpc, see DEPEND.
+KEYWORDS="~amd64 ~x86"
+IUSE="minimal python"
+
+DEPEND=">=dev-lang/fpc-${FPCVER}[source]
+ net-misc/rsync
+ x11-libs/gtk+:2
+ >=sys-devel/binutils-2.19.1-r1:="
+RDEPEND="${DEPEND}"
+
+RESTRICT="strip" #269221
+
+S="${WORKDIR}/${PN}"
+
+PATCHES=( "${FILESDIR}"/${PN}-0.9.26-fpcsrc.patch )
+
+src_prepare() {
+ default
+ # Use default configuration (minus stripping) unless specifically requested otherwise
+ if ! test ${PPC_CONFIG_PATH+set} ; then
+ local FPCVER=$(fpc -iV)
+ export PPC_CONFIG_PATH="${WORKDIR}"
+ sed -e 's/^FPBIN=/#&/' /usr/lib/fpc/${FPCVER}/samplecfg |
+ sh -s /usr/lib/fpc/${FPCVER} "${PPC_CONFIG_PATH}" || die
+ fi
+ sed -i \
+ -e "s;SecondaryConfigPath:='/etc/lazarus';SecondaryConfigPath:=ExpandFileNameUTF8('~/.lazarus');g" \
+ -e "s;PrimaryConfigPath:=ExpandFileNameUTF8('~/.lazarus');PrimaryConfigPath:='/etc/lazarus';g" \
+ ide/include/unix/lazbaseconf.inc \
+ || die
+}
+
+src_compile() {
+ LCL_PLATFORM=gtk2 emake \
+ $(usex minimal "" "bigide") \
+ -j1
+ if use python; then
+ addpredict ide/exttools.pas
+ ./lazbuild -B --lazarusdir="." --pcp="../lazarus-package-config" --build-ide= \
+ --add-package ../Python-for-Lazarus-${PYTHON_HASH}/python4lazarus/python4lazarus_package.lpk \
+ || die
+ sed -i -e "s:${WORKDIR}/Python-for-Lazarus-${PYTHON_HASH}:/etc/lazarus:g" \
+ ../lazarus-package-config/packagefiles.xml \
+ ../lazarus-package-config/idemake.cfg \
+ ../Python-for-Lazarus-${PYTHON_HASH}/python4lazarus/lib/x86_64-linux/python4lazarus_package.compiled \
+ || die
+ sed -i -e "s:${WORKDIR}/lazarus-package-config:/etc/lazarus:g" \
+ ../lazarus-package-config/idemake.cfg \
+ || die
+ fi
+}
+
+src_install() {
+ diropts -m0755
+ dodir /usr/share
+ # Using rsync to avoid unnecessary copies and cleaning...
+ # Note: *.o and *.ppu are needed
+ rsync -a \
+ --exclude="CVS" --exclude=".cvsignore" \
+ --exclude="*.ppw" --exclude="*.ppl" \
+ --exclude="*.ow" --exclude="*.a"\
+ --exclude="*.rst" --exclude=".#*" \
+ --exclude="*.~*" --exclude="*.bak" \
+ --exclude="*.orig" --exclude="*.rej" \
+ --exclude=".xvpics" --exclude="*.compiled" \
+ --exclude="killme*" --exclude=".gdb_hist*" \
+ --exclude="debian" --exclude="COPYING*" \
+ --exclude="*.app" \
+ "${S}" "${ED%/}"/usr/share \
+ || die "Unable to copy files!"
+
+ dosym ../share/lazarus/startlazarus /usr/bin/startlazarus
+ dosym ../share/lazarus/startlazarus /usr/bin/lazarus
+ dosym ../share/lazarus/lazbuild /usr/bin/lazbuild
+ use minimal || dosym ../share/lazarus/components/chmhelp/lhelp/lhelp /usr/bin/lhelp
+ dosym ../lazarus/images/ide_icon48x48.png /usr/share/pixmaps/lazarus.png
+
+ if use python; then
+ diropts -m0755
+ dodir /etc/lazarus
+ cp -rf ../lazarus-package-config/* \
+ "${ED%/}"/etc/lazarus || die
+ cp -rf ../Python-for-Lazarus-${PYTHON_HASH}/python4lazarus \
+ "${ED%/}"/etc/lazarus || die
+ fi
+
+ make_desktop_entry startlazarus "Lazarus IDE" "lazarus"
+}