summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-03-24 23:34:28 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2020-03-24 23:34:48 +0000
commit2f8caac4a356bdcab968b08105ae966fb514b3ef (patch)
treecf1bbdfe13c516ee8d72af8a006c8365fb7cd49b /dev-lang/ghc/files
parentprofiles: Drop media-sound/audacious-3.9, media-plugins/audacious-3.9-r3 (diff)
downloadgentoo-2f8caac4a356bdcab968b08105ae966fb514b3ef.tar.gz
gentoo-2f8caac4a356bdcab968b08105ae966fb514b3ef.tar.bz2
gentoo-2f8caac4a356bdcab968b08105ae966fb514b3ef.zip
dev-lang/ghc: bump up to 8.10.1
Package-Manager: Portage-2.3.95, Repoman-2.3.21 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-lang/ghc/files')
-rw-r--r--dev-lang/ghc/files/ghc-8.10.1-allow-cross-bootstrap.patch17
-rw-r--r--dev-lang/ghc/files/ghc-8.10.1-no-relax-everywhere.patch19
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-lang/ghc/files/ghc-8.10.1-allow-cross-bootstrap.patch b/dev-lang/ghc/files/ghc-8.10.1-allow-cross-bootstrap.patch
new file mode 100644
index 000000000000..7495cc8bff8d
--- /dev/null
+++ b/dev-lang/ghc/files/ghc-8.10.1-allow-cross-bootstrap.patch
@@ -0,0 +1,17 @@
+Allow using cross-compilers to bootstrap GHC.
+
+In my case I'm using "cross"-compiler from
+x86_64-unknown-linux to x86_64-HEAD-linux.
+
+Those targets have the same ABI and can boot one another.
+--- a/configure.ac
++++ b/configure.ac
+@@ -219,7 +219,7 @@ then
+ echo "This GHC (${WithGhc}) does not generate code for the build platform"
+ echo " GHC target platform : $bootstrap_target"
+ echo " Desired build platform : $BuildPlatform"
+- exit 1
++ #exit 1
+ fi
+
+ # Testing if we shall enable shared libs support on Solaris.
diff --git a/dev-lang/ghc/files/ghc-8.10.1-no-relax-everywhere.patch b/dev-lang/ghc/files/ghc-8.10.1-no-relax-everywhere.patch
new file mode 100644
index 000000000000..19c8b4bccc48
--- /dev/null
+++ b/dev-lang/ghc/files/ghc-8.10.1-no-relax-everywhere.patch
@@ -0,0 +1,19 @@
+https://github.com/gentoo-haskell/gentoo-haskell/issues/704
+
+Allow users to specify -W,--relax externally and pass
+-Wl,-no-relax unconditonally on all arches.
+
+Reported-by: wmyrda
+--- a/compiler/main/DriverPipeline.hs
++++ b/compiler/main/DriverPipeline.hs
+@@ -2144,9 +2144,7 @@ joinObjectFiles dflags o_files output_fn = do
+ -- gcc on sparc sets -Wl,--relax implicitly, but
+ -- -r and --relax are incompatible for ld, so
+ -- disable --relax explicitly.
+- ++ (if platformArch (targetPlatform dflags)
+- `elem` [ArchSPARC, ArchSPARC64]
+- && ldIsGnuLd
++ ++ (if ldIsGnuLd
+ then [SysTools.Option "-Wl,-no-relax"]
+ else [])
+ -- See Note [Produce big objects on Windows]