summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorneeshy <neeshy@tfwno.gf>2023-09-20 14:42:34 -0400
committerMiroslav Šulc <fordfrog@gentoo.org>2024-01-17 10:27:12 +0100
commit2ea8c495a7902eb08abdd2e4c0c7d660eb87bbad (patch)
treec033ed96904b7365c875242252437d3136e30d24 /dev-java
parentdev-java/xalan: dropped 2.7.3-r1 to unstable (diff)
downloadgentoo-2ea8c495a7902eb08abdd2e4c0c7d660eb87bbad.tar.gz
gentoo-2ea8c495a7902eb08abdd2e4c0c7d660eb87bbad.tar.bz2
gentoo-2ea8c495a7902eb08abdd2e4c0c7d660eb87bbad.zip
dev-java/xalan-serializer: build against java >=8
Signed-off-by: Nima Sadeghi <neeshy@tfwno.gf> Closes: https://github.com/gentoo/gentoo/pull/34852 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/xalan-serializer/xalan-serializer-2.7.3-r1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-java/xalan-serializer/xalan-serializer-2.7.3-r1.ebuild b/dev-java/xalan-serializer/xalan-serializer-2.7.3-r1.ebuild
new file mode 100644
index 000000000000..3234313f6ab6
--- /dev/null
+++ b/dev-java/xalan-serializer/xalan-serializer-2.7.3-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+JAVA_PKG_IUSE="doc source"
+MAVEN_ID="xalan:serializer:2.7.3"
+
+inherit java-pkg-2 java-pkg-simple verify-sig
+
+DESCRIPTION="Transforming XML documents into HTML, text, or other XML document types"
+HOMEPAGE="https://xalan.apache.org/"
+SRC_URI="mirror://apache/xalan/xalan-j/source/xalan-j_${PV//./_}-src.tar.gz
+ verify-sig? ( https://downloads.apache.org/xalan/xalan-j/source/xalan-j_${PV//./_}-src.tar.gz.asc )"
+
+S="${WORKDIR}/xalan-j_${PV//./_}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~arm arm64 ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+
+DEPEND=">=virtual/jdk-1.8:*"
+RDEPEND=">=virtual/jre-1.8:*"
+
+BDEPEND="verify-sig? ( sec-keys/openpgp-keys-apache-xalan-j )"
+VERIFY_SIG_OPENPGP_KEY_PATH="/usr/share/openpgp-keys/xalan-j.apache.org.asc"
+
+JAVA_MAIN_CLASS="org.apache.xml.serializer.Version"
+JAVA_RESOURCE_DIRS="resources"
+JAVA_SRC_DIR="src"
+
+src_prepare() {
+ java-pkg-2_src_prepare
+ # kill all non-serializer sources to ease javadocs and dosrc
+ find src/org/ -type f ! -path "src/org/apache/xml/serializer/*" -delete || die
+
+ # java-pkg-simple.eclass wants resources in JAVA_RESOURCE_DIRS
+ mkdir -p resources || die
+ pushd src > /dev/null || die
+ find org -type f \
+ ! -name '*.java' \
+ ! -name 'Version.src' \
+ ! -name 'package.html' \
+ | xargs cp --parent -t ../resources || die
+ popd > /dev/null || die
+}