summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authororbea <orbea@riseup.net>2023-02-05 10:08:05 -0800
committerSam James <sam@gentoo.org>2023-02-05 18:30:51 +0000
commit3df8e080250624f2fbb12983824c534be311b96c (patch)
tree5658cbe0d3616cda6f70a38bba0bbaecaccf79ce /dev-java/tomcat-native
parentdev-python/pkgcraft: add 0.0.4 (diff)
downloadgentoo-3df8e080250624f2fbb12983824c534be311b96c.tar.gz
gentoo-3df8e080250624f2fbb12983824c534be311b96c.tar.bz2
gentoo-3df8e080250624f2fbb12983824c534be311b96c.zip
dev-java/tomcat-native: Add upstream slibtool patch
Closes: https://bugs.gentoo.org/778914 Upstream-PR: https://github.com/apache/tomcat-native/pull/14 Upstream-Commit: https://github.com/apache/tomcat-native/commit/4f7fb7f442de3d9a9bb2f72b5dabc2f4bc8e3384 Closes: https://github.com/gentoo/gentoo/pull/29440 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-java/tomcat-native')
-rw-r--r--dev-java/tomcat-native/files/tomcat-native-2.0.2-slibtool.patch32
-rw-r--r--dev-java/tomcat-native/tomcat-native-2.0.2.ebuild15
2 files changed, 46 insertions, 1 deletions
diff --git a/dev-java/tomcat-native/files/tomcat-native-2.0.2-slibtool.patch b/dev-java/tomcat-native/files/tomcat-native-2.0.2-slibtool.patch
new file mode 100644
index 000000000000..e0378669aad5
--- /dev/null
+++ b/dev-java/tomcat-native/files/tomcat-native-2.0.2-slibtool.patch
@@ -0,0 +1,32 @@
+Upstream-PR: https://github.com/apache/tomcat-native/pull/14
+Upstream-Commit:
+https://github.com/apache/tomcat-native/commit/4f7fb7f442de3d9a9bb2f72b5dabc2f4bc8e3384
+
+From 54dccd3a4dc01801d9311b3160808305ec9fc2cf Mon Sep 17 00:00:00 2001
+From: orbea <orbea@riseup.net>
+Date: Thu, 21 Jul 2022 17:59:14 -0700
+Subject: [PATCH] native: Fix the build with rlibtool
+
+When building tomcat-native with slibtool using the rlibtool symlink the
+build will fail. This is because rlibtool requires the generated libtool
+script to determine if the build is shared, static or both.
+
+Gentoo bug: https://bugs.gentoo.org/778914
+---
+ native/configure.in | 3 +++
+ 1 file changed, 3 insertions(+)
+
+diff --git a/native/configure.in b/native/configure.in
+index 567894b10..e082ae6d2 100644
+--- a/native/configure.in
++++ b/native/configure.in
+@@ -50,6 +50,9 @@ AC_SUBST(TCN_CONFIG_LOCATION)
+ AC_CANONICAL_TARGET
+ AC_PROG_INSTALL
+
++dnl Generate the libtool script which is needed for rlibtool
++LT_INIT
++
+ dnl
+ dnl compute the top directory of the build
+ dnl note: this is needed for LIBTOOL and exporting the bundled Expat
diff --git a/dev-java/tomcat-native/tomcat-native-2.0.2.ebuild b/dev-java/tomcat-native/tomcat-native-2.0.2.ebuild
index 8fe559c51cd1..fa22022b8728 100644
--- a/dev-java/tomcat-native/tomcat-native-2.0.2.ebuild
+++ b/dev-java/tomcat-native/tomcat-native-2.0.2.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit java-pkg-2 java-ant-2 verify-sig
+inherit autotools java-pkg-2 java-ant-2 verify-sig
DESCRIPTION="Allows Tomcat to use certain native resources for better performance"
HOMEPAGE="https://tomcat.apache.org/native-doc/"
@@ -29,6 +29,19 @@ VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}/usr/share/openpgp-keys/tomcat-connectors.a
JAVA_ANT_REWRITE_CLASSPATH="yes"
+PATCHES=(
+ "${FILESDIR}"/${P}-slibtool.patch #778914
+)
+
+src_prepare() {
+ default
+
+ # Needed for the slibtool patch
+ cd native || die
+ sed -i 's/configure.in/configure.ac/' configure.in || die
+ eautoreconf
+}
+
src_configure() {
local myeconfargs=(
--with-apr="${EPREFIX}"/usr/bin/apr-1-config