summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/smack
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/smack')
-rw-r--r--dev-java/smack/Manifest1
-rw-r--r--dev-java/smack/metadata.xml5
-rw-r--r--dev-java/smack/smack-2.2.1.ebuild59
3 files changed, 65 insertions, 0 deletions
diff --git a/dev-java/smack/Manifest b/dev-java/smack/Manifest
new file mode 100644
index 000000000000..5800178a61c9
--- /dev/null
+++ b/dev-java/smack/Manifest
@@ -0,0 +1 @@
+DIST smack-dev-2.2.1.tar.gz 4052596 SHA256 8706d0c2fb72a94f3a8c33e720f49fb3ec5179ddd7df87d484f86a775b176814 SHA512 a6f6f70a61dec69ec2f3c82544f83100bf4ef39aa657ed7a8ce635be8484d3ed2cb539961286482ccc9f607520e0646e14668a17b4004ae6bd157b3d894146f0 WHIRLPOOL e75b979afe34f060b84d687f501e9f028fd97d3693647d346ae81bc9dd468819249931fa34d1145b781d875e65e9a83c6d60f6c477e961f9df9c6a4a8d1949d6
diff --git a/dev-java/smack/metadata.xml b/dev-java/smack/metadata.xml
new file mode 100644
index 000000000000..250f2d1940ea
--- /dev/null
+++ b/dev-java/smack/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+</pkgmetadata>
diff --git a/dev-java/smack/smack-2.2.1.ebuild b/dev-java/smack/smack-2.2.1.ebuild
new file mode 100644
index 000000000000..9c0feff9d4f1
--- /dev/null
+++ b/dev-java/smack/smack-2.2.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-ant-2
+
+MY_PN="${PN}-dev"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="An Open Source XMPP (Jabber) client library for instant messaging and presence"
+HOMEPAGE="http://www.jivesoftware.org/smack/"
+SRC_URI="http://www.jivesoftware.org/builds/${PN}/${MY_P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="2.2"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+COMMON_DEP="dev-java/xpp3"
+
+DEPEND=">=virtual/jdk-1.4
+ ${COMMON_DEP}"
+RDEPEND=">=virtual/jre-1.4
+ ${COMMON_DEP}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+
+ unpack ${A}
+
+ cd "${S}"
+ rm -f *.jar build/lib/*.jar build/merge/*.jar build/*.jar
+
+ cd "${S}/build/lib/"
+ java-pkg_jar-from xpp3
+
+ sed -i -e '/zipfileset/d' "${S}/build/build.xml" || die
+
+}
+
+EANT_BUILD_XML="build/build.xml"
+EANT_EXTRA_ARGS="-Djavadoc.dest.dir=api"
+
+src_install() {
+
+ java-pkg_dojar *.jar
+
+ dohtml *.html
+
+ use doc && {
+ java-pkg_dohtml -r documentation/*
+ java-pkg_dojavadoc api
+ }
+ use source && java-pkg_dosrc source/*
+
+}