summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/jpf
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/jpf')
-rw-r--r--dev-java/jpf/Manifest1
-rw-r--r--dev-java/jpf/jpf-1.5.1.ebuild47
-rw-r--r--dev-java/jpf/metadata.xml8
3 files changed, 56 insertions, 0 deletions
diff --git a/dev-java/jpf/Manifest b/dev-java/jpf/Manifest
new file mode 100644
index 000000000000..64718e7683ac
--- /dev/null
+++ b/dev-java/jpf/Manifest
@@ -0,0 +1 @@
+DIST jpf-src-1.5.1.zip 1115573 SHA256 93bc9852b9d86f788f5e3c53650aa11a18758526542e0ebc17a508818e91c2e4 SHA512 90326013b110f5729e25bde3f61985f7bee9f78c58ebc3631c271c3d02fc7e91851adf3aa79de71b8e1a1411a2d3b67ba8e4e13f55c9332505ea2adbbc00149b WHIRLPOOL 8530c8e01e034dcc4a642d6756d1bbf48572ed7dc15548bdd448847c661acfc80b6cc1d60f8bf147aab7e314114d077b6924768cfe2e2e7b04b371f3aacb5d52
diff --git a/dev-java/jpf/jpf-1.5.1.ebuild b/dev-java/jpf/jpf-1.5.1.ebuild
new file mode 100644
index 000000000000..6f637194ccb8
--- /dev/null
+++ b/dev-java/jpf/jpf-1.5.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=1
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Java Plugin Framework - a runtime engine that dynamically discovers and loads plugins"
+HOMEPAGE="http://${PN}.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${PN}-src-${PV}.zip"
+LICENSE="LGPL-2.1"
+
+SLOT="1.5"
+KEYWORDS="amd64 ~ppc x86"
+IUSE=""
+
+S="${WORKDIR}"
+
+COMMON_DEP="dev-java/commons-logging:0
+ dev-java/ant-core"
+DEPEND="app-arch/unzip
+ >=virtual/jdk-1.5
+ ${COMMON_DEP}"
+RDEPEND=">=virtual/jre-1.5
+ ${COMMON_DEP}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ java-ant_rewrite-classpath
+ rm -fv lib/*.jar || die
+ # needs some not yet packaged jxp dep, will add only on demand
+ rm -rfv source-tools/org/java/plugin/tools/{docgen,ant/DocTask.java} || die
+}
+
+# doc target is name="-javadoc" and would need a patch, on demand
+EANT_GENTOO_CLASSPATH="commons-logging,ant-core"
+
+src_install() {
+ java-pkg_dojar build/lib/jpf*.jar
+ java-pkg_register-ant-task
+
+ newdoc README.txt README || die
+ dodoc changelog.txt || die
+}
diff --git a/dev-java/jpf/metadata.xml b/dev-java/jpf/metadata.xml
new file mode 100644
index 000000000000..9c3dfc5d5f17
--- /dev/null
+++ b/dev-java/jpf/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+ <upstream>
+ <remote-id type="sourceforge">jpf</remote-id>
+ </upstream>
+</pkgmetadata>