summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/istack-commons-runtime
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/istack-commons-runtime')
-rw-r--r--dev-java/istack-commons-runtime/Manifest3
-rw-r--r--dev-java/istack-commons-runtime/istack-commons-runtime-2.22.ebuild22
-rw-r--r--dev-java/istack-commons-runtime/istack-commons-runtime-20070122-r1.ebuild42
-rw-r--r--dev-java/istack-commons-runtime/istack-commons-runtime-20090620-r1.ebuild60
-rw-r--r--dev-java/istack-commons-runtime/metadata.xml5
5 files changed, 132 insertions, 0 deletions
diff --git a/dev-java/istack-commons-runtime/Manifest b/dev-java/istack-commons-runtime/Manifest
new file mode 100644
index 000000000000..81bcde5dc79e
--- /dev/null
+++ b/dev-java/istack-commons-runtime/Manifest
@@ -0,0 +1,3 @@
+DIST istack-commons-20070122.tar.bz2 10360 SHA256 dc8c86bb11f7ddd4c1c50ca0925d59ade16b5dc74bcd983fe95a08e104662a8e SHA512 120b9b8db52cebe507e8711dd4fcdc1a12db8d2320ff9054e1fa6688a321cbb18d25f6beb06e11a091c1cbc2870ab07e9df9681784893c5f0d6f36ae4b7e12f6 WHIRLPOOL b4d47b9d73ecd26c2effd287642521d8ecd6741c6df140bd024aa54770ddf1084d504ade53505e27dda66e3204e2625dcb63c40df1d098e4baed76f5371a55ee
+DIST istack-commons-20090620-src.tar.bz2 30194 SHA256 0719fbc462f98bfb66e9606fad11845797a2ba7dd54ad780e07e16c63f3ea899 SHA512 8a037852a19dd8ecf66fd6b6ca1454503e9f3d36ee716d774a1eb70245a60cf21c7e14ae97d811953d68475c4ea9bef7b9470d0ab82363481dc0f71c2865d2d4 WHIRLPOOL 68f8427892ff95390bf418c874dccd84aefe5c04f26e40b42f1f3e6fbe85a81f695365c1ff3b34eab0a4ebf42476301434555ed43d556f39f597bcd4c6861630
+DIST istack-commons-runtime-2.22-sources.jar 33136 SHA256 06520c4566d7ab28358ce06f03caaf7f44ebccca8b79fdb5d4ddc4df221911bb SHA512 cfabed991cadfa3562a2a281f4b3bdabadd753cd3b9ee918b3f89428e416c0d23aed928d5f61bde4f3958d12f4cb63130354cbf6bf14577ed54871a46d703bdd WHIRLPOOL d35c96f6d7658dceaa7dacf6a23f6993c7f5a0755557f24ad4f23db3a750c635dfa8769b145e100c378050136df27b46fd0ee389a458cd694cab712a019db075
diff --git a/dev-java/istack-commons-runtime/istack-commons-runtime-2.22.ebuild b/dev-java/istack-commons-runtime/istack-commons-runtime-2.22.ebuild
new file mode 100644
index 000000000000..fef9358ad89d
--- /dev/null
+++ b/dev-java/istack-commons-runtime/istack-commons-runtime-2.22.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit java-pkg-2 java-pkg-simple
+
+MY_PN=${PN%%-*}
+
+DESCRIPTION="IStack Commons - Runtime jar"
+HOMEPAGE="https://istack-commons.java.net"
+SRC_URI="https://maven.java.net/content/repositories/releases/com/sun/${MY_PN}/${PN}/${PV}/${P}-sources.jar"
+
+LICENSE="CDDL"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND=">=virtual/jre-1.6"
+DEPEND=">=virtual/jdk-1.6
+ app-arch/unzip"
diff --git a/dev-java/istack-commons-runtime/istack-commons-runtime-20070122-r1.ebuild b/dev-java/istack-commons-runtime/istack-commons-runtime-20070122-r1.ebuild
new file mode 100644
index 000000000000..e0d761ea46d1
--- /dev/null
+++ b/dev-java/istack-commons-runtime/istack-commons-runtime-20070122-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+JAVA_PKG_IUSE="source"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="istack-commons"
+HOMEPAGE="https://istack-commons.dev.java.net/"
+SRC_URI="mirror://gentoo/istack-commons-${PV}.tar.bz2"
+
+LICENSE="CDDL"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~x86-fbsd"
+IUSE=""
+
+COMMON_DEP="java-virtuals/jaf"
+
+DEPEND=">=virtual/jdk-1.5
+ ${COMMON_DEP}"
+RDEPEND=">=virtual/jre-1.5
+ ${COMMON_DEP}"
+
+S="${WORKDIR}/istack-commons-${PV}"
+
+src_unpack() {
+ unpack ${A}
+
+ java-ant_bsfix_one "${S}/build-common.xml"
+
+ java-pkg_jarfrom --into "${S}/runtime/lib" --virtual jaf
+}
+
+EANT_BUILD_XML="runtime/build.xml"
+
+src_install() {
+
+ java-pkg_dojar runtime/build/istack-commons-runtime.jar
+
+ use source && java-pkg_dosrc runtime/src/*
+}
diff --git a/dev-java/istack-commons-runtime/istack-commons-runtime-20090620-r1.ebuild b/dev-java/istack-commons-runtime/istack-commons-runtime-20090620-r1.ebuild
new file mode 100644
index 000000000000..46da96eee982
--- /dev/null
+++ b/dev-java/istack-commons-runtime/istack-commons-runtime-20090620-r1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+JAVA_PKG_IUSE="source"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="istack-commons"
+HOMEPAGE="https://istack-commons.dev.java.net/"
+PROJ_PN="istack-commons"
+PROJ_P="${PROJ_PN}-${PV}"
+SRC_FILE="${PROJ_P}-src.tar.bz2"
+SRC_URI="mirror://gentoo/${SRC_FILE}"
+
+LICENSE="CDDL"
+SLOT="1.1"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE=""
+
+COMMON_DEP="
+ java-virtuals/jaf
+ java-virtuals/stax-api"
+
+DEPEND=">=virtual/jdk-1.5
+ ${COMMON_DEP}"
+RDEPEND=">=virtual/jre-1.5
+ ${COMMON_DEP}"
+
+S="${WORKDIR}/${PROJ_P}"
+
+# Helper to generate the tarball :-)
+# ( PN=istack-commons-runtime ; PV=20090620 ; P="${PN}-${PV}" ; . ${P}.ebuild ; src_tarball )
+src_tarball() {
+ CVSROOT=':pserver:guest@cvs.dev.java.net:/cvs'
+ PROJ_PN='istack-commons'
+ cvs -d "${CVSROOT}" \
+ export -D $PV -d "${PROJ_P}" \
+ "${PROJ_PN}/${PROJ_PN}" && \
+ tar cvjf "${SRC_FILE}" \
+ --exclude '*.zip' \
+ --exclude '*.jar' \
+ "${PROJ_P}" \
+ && \
+ echo "New tarball located at ${SRC_FILE}"
+}
+
+java_prepare() {
+ java-ant_bsfix_one "${S}/build-common.xml"
+ java-pkg_jarfrom --into "${S}/runtime/lib" --virtual jaf
+ java-pkg_jarfrom --into "${S}/runtime/lib" --virtual stax-api
+}
+
+EANT_BUILD_XML="runtime/build.xml"
+
+src_install() {
+ java-pkg_dojar runtime/build/istack-commons-runtime.jar
+ use source && java-pkg_dosrc runtime/src/*
+}
diff --git a/dev-java/istack-commons-runtime/metadata.xml b/dev-java/istack-commons-runtime/metadata.xml
new file mode 100644
index 000000000000..250f2d1940ea
--- /dev/null
+++ b/dev-java/istack-commons-runtime/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+</pkgmetadata>