summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/icedtea-sound
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/icedtea-sound')
-rw-r--r--dev-java/icedtea-sound/Manifest1
-rw-r--r--dev-java/icedtea-sound/icedtea-sound-1.0.1.ebuild41
-rw-r--r--dev-java/icedtea-sound/metadata.xml13
3 files changed, 55 insertions, 0 deletions
diff --git a/dev-java/icedtea-sound/Manifest b/dev-java/icedtea-sound/Manifest
new file mode 100644
index 000000000000..62a3da692e0f
--- /dev/null
+++ b/dev-java/icedtea-sound/Manifest
@@ -0,0 +1 @@
+DIST icedtea-sound-1.0.1.tar.xz 1515308 SHA256 6ff852b82ae7db7a95981271037eb3a3d52c59581e3b27a638a7c6bc8eecb4a3 SHA512 505d02f5ce885d4c7638cde8042a686aa3651de9072d325db6fefb8c5bd3d7de73253b27162555396e827a65f50aeed8326e99099757d5efe18d14ccebc1c07a WHIRLPOOL aaf495c4be15ba6c656797118691128732166049a38a535804852ac5fe4c4c555017f1777a1b96cba463e8933f90a0656f1b077b88bc80291fb99007e071ad1f
diff --git a/dev-java/icedtea-sound/icedtea-sound-1.0.1.ebuild b/dev-java/icedtea-sound/icedtea-sound-1.0.1.ebuild
new file mode 100644
index 000000000000..b8f1d60fa776
--- /dev/null
+++ b/dev-java/icedtea-sound/icedtea-sound-1.0.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+# Build written by Andrew John Hughes (gnu_andrew@member.fsf.org)
+
+EAPI="5"
+
+inherit eutils java-pkg-2 prefix
+
+DESCRIPTION="Plugins for javax.sound"
+HOMEPAGE="http://icedtea.classpath.org"
+SRC_URI="http://icedtea.classpath.org/download/source/${P}.tar.xz"
+
+LICENSE="GPL-2-with-linking-exception"
+SLOT="0"
+KEYWORDS="amd64 ~arm ppc x86"
+
+IUSE="+doc test"
+
+COMMON_DEP="
+ >=virtual/jdk-1.6.0
+ >=media-sound/pulseaudio-0.9.11:="
+RDEPEND="${COMMON_DEP}"
+DEPEND="${COMMON_DEP}"
+
+pkg_setup() {
+ JAVA_PKG_WANT_SOURCE="1.6"
+ JAVA_PKG_WANT_TARGET="1.6"
+
+ java-pkg-2_pkg_setup
+}
+
+src_configure() {
+ econf --with-jdk-home="${JAVA_HOME}" \
+ $(use_enable doc docs) \
+ --htmldir="${EROOT}usr/share/doc/${PF}/html"
+}
+
+src_compile() {
+ default
+}
diff --git a/dev-java/icedtea-sound/metadata.xml b/dev-java/icedtea-sound/metadata.xml
new file mode 100644
index 000000000000..c254d5eecdf9
--- /dev/null
+++ b/dev-java/icedtea-sound/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+ <maintainer>
+ <email>gnu_andrew@member.fsf.org</email>
+ <name>Andrew John Hughes</name>
+ <description>Proxy Maintainer</description>
+ </maintainer>
+ <longdescription>
+ Plugins for javax.sound, including the PulseAudio support formerly bundled with IcedTea.
+ </longdescription>
+</pkgmetadata>