summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/gnu-crypto
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/gnu-crypto')
-rw-r--r--dev-java/gnu-crypto/Manifest1
-rw-r--r--dev-java/gnu-crypto/files/gnu-crypto-2.0.1-jdk15.patch30
-rw-r--r--dev-java/gnu-crypto/gnu-crypto-2.0.1-r2.ebuild52
-rw-r--r--dev-java/gnu-crypto/gnu-crypto-2.0.1-r3.ebuild67
-rw-r--r--dev-java/gnu-crypto/metadata.xml13
5 files changed, 163 insertions, 0 deletions
diff --git a/dev-java/gnu-crypto/Manifest b/dev-java/gnu-crypto/Manifest
new file mode 100644
index 000000000000..3fdfb7d61ab4
--- /dev/null
+++ b/dev-java/gnu-crypto/Manifest
@@ -0,0 +1 @@
+DIST gnu-crypto-2.0.1.tar.bz2 3895714 SHA256 a7398758a5dd62f2a30bd083c3646092006d51a63b7a91ab608dc2c80d569d2c SHA512 c14aa73fb23663559195e8fc7f85a220b25078fa8ab4e7cf43b84febe96599d990ccf52fcf1f6f66f2b547d9b644bbc99b3d44dc4a777dcb72530e58c8509015 WHIRLPOOL 1ce73d64e763ef04157915938e661999bdc7861940f5d9bfbea35601b9345b05baf5ba60dbcce17d2892a1cae3d31fead53363c44306cbd4951dbce9bcefa3e2
diff --git a/dev-java/gnu-crypto/files/gnu-crypto-2.0.1-jdk15.patch b/dev-java/gnu-crypto/files/gnu-crypto-2.0.1-jdk15.patch
new file mode 100644
index 000000000000..47957cc5ec5f
--- /dev/null
+++ b/dev-java/gnu-crypto/files/gnu-crypto-2.0.1-jdk15.patch
@@ -0,0 +1,30 @@
+diff -Nur gnu-crypto-2.0.1/source/gnu/crypto/sasl/ClientMechanism.java gnu-crypto-2.0.1-new/source/gnu/crypto/sasl/ClientMechanism.java
+--- gnu-crypto-2.0.1/source/gnu/crypto/sasl/ClientMechanism.java 2003-11-21 10:22:10.000000000 +0100
++++ gnu-crypto-2.0.1-new/source/gnu/crypto/sasl/ClientMechanism.java 2005-05-24 16:16:37.493727834 +0200
+@@ -140,9 +140,9 @@
+ return mechanism;
+ }
+
+- public Object getNegotiatedProperty(final String propName) throws SaslException {
++ public Object getNegotiatedProperty(final String propName) {
+ if (!isComplete()) {
+- throw new IllegalMechanismStateException();
++ throw new IllegalStateException();
+ }
+ if (Sasl.QOP.equals(propName)) {
+ return getNegotiatedQOP();
+diff -Nur gnu-crypto-2.0.1/source/gnu/crypto/sasl/ServerMechanism.java gnu-crypto-2.0.1-new/source/gnu/crypto/sasl/ServerMechanism.java
+--- gnu-crypto-2.0.1/source/gnu/crypto/sasl/ServerMechanism.java 2003-11-21 10:26:14.000000000 +0100
++++ gnu-crypto-2.0.1-new/source/gnu/crypto/sasl/ServerMechanism.java 2005-05-24 16:16:55.503085024 +0200
+@@ -147,9 +147,9 @@
+ return this.authorizationID;
+ }
+
+- public Object getNegotiatedProperty(final String propName) throws SaslException {
++ public Object getNegotiatedProperty(final String propName) {
+ if (!isComplete()) {
+- throw new IllegalMechanismStateException();
++ throw new IllegalStateException();
+ }
+ if (Sasl.QOP.equals(propName)) {
+ return getNegotiatedQOP();
diff --git a/dev-java/gnu-crypto/gnu-crypto-2.0.1-r2.ebuild b/dev-java/gnu-crypto/gnu-crypto-2.0.1-r2.ebuild
new file mode 100644
index 000000000000..bb631a1c189c
--- /dev/null
+++ b/dev-java/gnu-crypto/gnu-crypto-2.0.1-r2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 eutils
+
+DESCRIPTION="GNU Crypto cryptographic primitives for Java"
+HOMEPAGE="http://www.gnu.org/software/gnu-crypto/"
+SRC_URI="ftp://ftp.gnupg.org/GnuPG/gnu-crypto/gnu-crypto-2.0.1.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE=""
+
+DEPEND=">=virtual/jdk-1.3"
+RDEPEND=">=virtual/jre-1.3"
+
+RESTRICT="test"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-jdk15.patch"
+}
+
+src_configure() {
+ # jikes support disabled, doesnt work: #86655
+ econf JAVAC="javac" JAVACFLAGS="$(java-pkg_javac-args)" --with-jce=yes --with-sasl=yes
+}
+
+src_compile() {
+ emake -j1
+ if use doc ; then
+ emake -j1 javadoc
+ fi
+}
+
+src_install() {
+ einstall
+ rm "${ED}"/usr/share/*.jar
+
+ java-pkg_dojar source/gnu-crypto.jar
+ java-pkg_dojar jce/javax-crypto.jar
+ java-pkg_dojar security/javax-security.jar
+
+ use doc && java-pkg_dojavadoc api
+ use source && java-pkg_dosrc source/* jce/* security/*
+
+ dodoc AUTHORS ChangeLog NEWS README THANKS
+}
diff --git a/dev-java/gnu-crypto/gnu-crypto-2.0.1-r3.ebuild b/dev-java/gnu-crypto/gnu-crypto-2.0.1-r3.ebuild
new file mode 100644
index 000000000000..f06c563f37b7
--- /dev/null
+++ b/dev-java/gnu-crypto/gnu-crypto-2.0.1-r3.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+JAVA_PKG_IUSE="doc source test"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="GNU Crypto cryptographic primitives for Java"
+HOMEPAGE="http://www.gnu.org/software/gnu-crypto/"
+SRC_URI="ftp://ftp.gnupg.org/GnuPG/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc ~ppc64 x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE=""
+
+DEPEND=">=virtual/jdk-1.6"
+RDEPEND=">=virtual/jre-1.6"
+
+EANT_BUILD_XML="${S}/build.xml"
+EANT_BUILD_TARGET="jar"
+
+EANT_DOC_TARGET="javadoc"
+
+java_prepare() {
+ epatch "${FILESDIR}/${P}-jdk15.patch"
+}
+
+src_compile() {
+ java-pkg-2_src_compile
+}
+
+src_test() {
+ local TEST_TARGETS=(
+ check
+ ent
+ )
+
+ for target in ${TEST_TARGETS[@]}; do
+ EANT_TEST_TARGET=${target} \
+ java-pkg-2_src_test
+ done
+}
+
+src_install() {
+ local GNU_CRYPTO_JARS=(
+ "${PN}"
+ javax-crypto
+ javax-security
+ )
+
+ if use test; then
+ GNU_CRYPTO_JARS=(${GNU_CRYPTO_JARS[@]} "${PN}-test")
+ fi
+
+ for jar in ${GNU_CRYPTO_JARS[@]}; do
+ java-pkg_dojar "lib/${jar}.jar"
+ done
+
+ use doc && java-pkg_dojavadoc docs/api
+ use source && java-pkg_dosrc source/* jce/* security/*
+
+ dodoc AUTHORS ChangeLog NEWS README THANKS
+}
diff --git a/dev-java/gnu-crypto/metadata.xml b/dev-java/gnu-crypto/metadata.xml
new file mode 100644
index 000000000000..3a7ea50b6a43
--- /dev/null
+++ b/dev-java/gnu-crypto/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+<herd>java</herd>
+
+<longdescription>
+GNU Crypto, part of the GNU project, released under the aegis of GNU,
+aims at providing free, versatile, high-quality, and provably correct
+implementations of cryptographic primitives and tools in the Java
+programming language for use by programmers and end-users.
+</longdescription>
+</pkgmetadata>