summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJack Todaro <solpeth@posteo.org>2022-08-07 12:09:13 +1000
committerSam James <sam@gentoo.org>2022-08-10 04:34:46 +0100
commit069e8497134164fba8ab4d729c77643a87588c0c (patch)
treeb880414bee4ebf410387aef0f72f66363580caa7 /dev-haskell/tls/tls-1.5.8.ebuild
parentdev-haskell/semigroupoids: refresh metadata.xml (diff)
downloadgentoo-069e8497134164fba8ab4d729c77643a87588c0c.tar.gz
gentoo-069e8497134164fba8ab4d729c77643a87588c0c.tar.bz2
gentoo-069e8497134164fba8ab4d729c77643a87588c0c.zip
dev-haskell/tls: add 1.5.8
Bug: https://bugs.gentoo.org/863191 Signed-off-by: Jack Todaro <solpeth@posteo.org> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell/tls/tls-1.5.8.ebuild')
-rw-r--r--dev-haskell/tls/tls-1.5.8.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-haskell/tls/tls-1.5.8.ebuild b/dev-haskell/tls/tls-1.5.8.ebuild
new file mode 100644
index 000000000000..e020a9f1e3e6
--- /dev/null
+++ b/dev-haskell/tls/tls-1.5.8.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.7.1.1.9999
+#hackport: flags: -hans
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="TLS/SSL protocol native implementation (Server and Client)"
+HOMEPAGE="https://github.com/vincenthz/hs-tls"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE="+compat +network"
+
+RDEPEND="dev-haskell/asn1-encoding:=[profile?]
+ >=dev-haskell/asn1-types-0.2.0:=[profile?]
+ >=dev-haskell/async-2.0:=[profile?]
+ >=dev-haskell/cereal-0.5.3:=[profile?]
+ >=dev-haskell/cryptonite-0.27:=[profile?]
+ dev-haskell/data-default-class:=[profile?]
+ dev-haskell/hourglass:=[profile?]
+ >=dev-haskell/memory-0.14.6:=[profile?]
+ >=dev-haskell/x509-1.7.5:=[profile?]
+ >=dev-haskell/x509-store-1.6:=[profile?]
+ >=dev-haskell/x509-validation-1.6.5:=[profile?]
+ >=dev-lang/ghc-8.4.3:=
+ network? ( >=dev-haskell/network-2.4.0.0:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2.0.1
+ test? ( dev-haskell/quickcheck
+ dev-haskell/tasty
+ dev-haskell/tasty-quickcheck )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag compat compat) \
+ --flag=-hans \
+ $(cabal_flag network network)
+}