summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhololeap <hololeap@protonmail.com>2023-10-02 23:09:36 -0600
committerSam James <sam@gentoo.org>2023-10-23 04:10:05 +0100
commit6bd996c92cab8a73a03eae6299e1ac3e3c39f4fa (patch)
treeac00394fcbccd0ed7396e58147b7a3fa5e07b195 /dev-haskell/shelly
parentdev-haskell/setlocale: Migrate to CABAL_CHDEPS (diff)
downloadgentoo-6bd996c92cab8a73a03eae6299e1ac3e3c39f4fa.tar.gz
gentoo-6bd996c92cab8a73a03eae6299e1ac3e3c39f4fa.tar.bz2
gentoo-6bd996c92cab8a73a03eae6299e1ac3e3c39f4fa.zip
dev-haskell/shelly: add 1.12.1
Signed-off-by: hololeap <hololeap@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell/shelly')
-rw-r--r--dev-haskell/shelly/Manifest1
-rw-r--r--dev-haskell/shelly/metadata.xml26
-rw-r--r--dev-haskell/shelly/shelly-1.12.1.ebuild78
3 files changed, 83 insertions, 22 deletions
diff --git a/dev-haskell/shelly/Manifest b/dev-haskell/shelly/Manifest
index 4f1c8ddb5d8b..4a9ca3c40042 100644
--- a/dev-haskell/shelly/Manifest
+++ b/dev-haskell/shelly/Manifest
@@ -1 +1,2 @@
+DIST shelly-1.12.1.tar.gz 75543 BLAKE2B db34e1a5e708192458e5d228b4758aa26812a3f547e39981754f8e3bb7af521c3887fde8e1b859a69b82edafc70be9979af30c918232a15e842f4e9894ed54ee SHA512 3917a03a23e61d5618f897f0ee90a4823980239252f260312ca86c7b364459c58749400e50a0f2ab78822c2eb6283891f993d2f31f0048a3cece19d5c565f05f
DIST shelly-1.9.0.tar.gz 73344 BLAKE2B f12e8835be5dd648427ff92b73bc9a37215a47067e65456c4c3dc8e9c2e5bb610da171648aadf9759e9a91eb075fa74d06241f83977a5380f49bc861643707cc SHA512 7c1eb25439e08095187746d0101fd92ad56ebb5a706820bad7330667cfc806066d4675c677e5d267440d4af7b517f36449e8f5e75332521780b564edc1586254
diff --git a/dev-haskell/shelly/metadata.xml b/dev-haskell/shelly/metadata.xml
index 42a79a9eb443..4894a131f231 100644
--- a/dev-haskell/shelly/metadata.xml
+++ b/dev-haskell/shelly/metadata.xml
@@ -5,29 +5,11 @@
<email>haskell@gentoo.org</email>
<name>Gentoo Haskell</name>
</maintainer>
- <longdescription>
- Shelly provides convenient systems programming in Haskell,
- similar in spirit to POSIX shells. Shelly:
-
- * is aimed at convenience and getting things done rather than
- being a demonstration of elegance.
-
- * has detailed and useful error messages
-
- * maintains its own environment, making it thread-safe.
-
- * is modern, using Text and system-filepath/system-fileio
-
- Shelly is originally forked from the Shellish package.
-
- See the shelly-extra package for additional functionality.
-
- An overview is available in the README: &lt;https://github.com/yesodweb/Shelly.hs/blob/master/README.md&gt;
- </longdescription>
- <upstream>
- <remote-id type="github">gregwebs/Shelly.hs</remote-id>
- </upstream>
<use>
<flag name="lifted">run the tests against Shelly.Lifted</flag>
</use>
+ <upstream>
+ <remote-id type="hackage">shelly</remote-id>
+ <remote-id type="github">gregwebs/Shelly.hs</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/dev-haskell/shelly/shelly-1.12.1.ebuild b/dev-haskell/shelly/shelly-1.12.1.ebuild
new file mode 100644
index 000000000000..b1b5c5236491
--- /dev/null
+++ b/dev-haskell/shelly/shelly-1.12.1.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.4.0.9999
+#hackport: flags: build-examples:examples
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="shell-like (systems) programming in Haskell"
+HOMEPAGE="https://github.com/gregwebs/Shelly.hs"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="examples lifted"
+
+RDEPEND="
+ >=dev-haskell/async-2.2.3:=[profile?]
+ >=dev-haskell/enclosed-exceptions-1.0.1:=[profile?]
+ >=dev-haskell/lifted-async-0.10.2:=[profile?]
+ >=dev-haskell/lifted-base-0.2.3.2:=[profile?]
+ >=dev-haskell/monad-control-0.3.2:=[profile?] <dev-haskell/monad-control-1.1:=[profile?]
+ >=dev-haskell/text-1.2.3.1:=[profile?]
+ >=dev-haskell/transformers-base-0.4.5:=[profile?]
+ >=dev-haskell/unix-compat-0.4.1.1:=[profile?] <dev-haskell/unix-compat-0.8:=[profile?]
+ >=dev-lang/ghc-8.10.6:=
+"
+DEPEND="
+ ${RDEPEND}
+ >=dev-haskell/cabal-3.2.1.0
+ test? (
+ >=dev-haskell/hspec-2.2.2
+ dev-haskell/hspec-contrib
+ >=dev-haskell/hunit-1.2.5.2
+ )
+"
+
+example_exes=(
+ "drain"
+ "run-handles"
+ "Color"
+)
+
+src_prepare() {
+ for e in "${example_exes[@]}"; do
+ export CABAL_CHDEPS=(
+ "${CABAL_CHDEPS[@]}"
+ "Executable ${e}"
+ "executable ${PN}-examples-${e}"
+ )
+ done
+
+ haskell-cabal_src_prepare
+}
+
+src_configure() {
+ config_flags=(
+ $(cabal_flag examples build-examples)
+ $(cabal_flag lifted lifted)
+ )
+
+ haskell-cabal_src_configure "${config_flags[@]}"
+}
+
+pkg_postinst() {
+ ghc-package_pkg_postinst
+
+ elog "The following example executables installed with this package have been"
+ elog "renamed to help prevent name collisions:"
+ elog ""
+
+ for e in "${example_exes[@]}"; do
+ elog "${e} -> ${PN}-examples-${e}"
+ done
+}