summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-haskell/crypto-cipher-types
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-haskell/crypto-cipher-types')
-rw-r--r--dev-haskell/crypto-cipher-types/Manifest2
-rw-r--r--dev-haskell/crypto-cipher-types/crypto-cipher-types-0.0.5.ebuild27
-rw-r--r--dev-haskell/crypto-cipher-types/crypto-cipher-types-0.0.9.ebuild27
-rw-r--r--dev-haskell/crypto-cipher-types/metadata.xml11
4 files changed, 67 insertions, 0 deletions
diff --git a/dev-haskell/crypto-cipher-types/Manifest b/dev-haskell/crypto-cipher-types/Manifest
new file mode 100644
index 000000000000..fe68c6afb267
--- /dev/null
+++ b/dev-haskell/crypto-cipher-types/Manifest
@@ -0,0 +1,2 @@
+DIST crypto-cipher-types-0.0.5.tar.gz 5188 SHA256 54e24b53d9f6cc7f344196a66c9e08adac2b8a9a51c2682ea31f364a4b551ad8 SHA512 80766372e8f4def100b46080a8527aebbd3d5f78281a969fdc1901ba522338e1f9a6ec057de0880cbd2454bcc9835771238895ae5fd3025aee70090d87554f17 WHIRLPOOL 3dc733ec5743656732eceb89305db572833f86b595f475a3e19ad74eb456b497bea1269e1882631f5f05d5df2ad7e3a37fc74d200736ad962491c652b7555cdf
+DIST crypto-cipher-types-0.0.9.tar.gz 8073 SHA256 2073f6b70df7916aebe2da49d224497183662d56d19da87b76f70039430c0a0f SHA512 9b369dfbe1baa918f8b72dca0a6637634582629ccd46226a3a89813f42cca1e11ee738e1053503a6bc2863c04dd885083e6a09a5bda5a52dbf381e9f133e24cc WHIRLPOOL 0d8cda5f1f78824c9d62eb1601fc769d1f5864a1962e3aa50df5f44a6fa79db4ed28442807e6de116ae89492a9be7771ceb2549da8df1122cbcd54df6aaedf24
diff --git a/dev-haskell/crypto-cipher-types/crypto-cipher-types-0.0.5.ebuild b/dev-haskell/crypto-cipher-types/crypto-cipher-types-0.0.5.ebuild
new file mode 100644
index 000000000000..2e4769ec5a56
--- /dev/null
+++ b/dev-haskell/crypto-cipher-types/crypto-cipher-types-0.0.5.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.3.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Generic cryptography cipher types"
+HOMEPAGE="http://github.com/vincenthz/hs-crypto-cipher"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/byteable-0.1.1:=[profile?]
+ >=dev-haskell/securemem-0.1.1:=[profile?]
+ >=dev-lang/ghc-6.10.4:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+"
diff --git a/dev-haskell/crypto-cipher-types/crypto-cipher-types-0.0.9.ebuild b/dev-haskell/crypto-cipher-types/crypto-cipher-types-0.0.9.ebuild
new file mode 100644
index 000000000000..afb63bee4c85
--- /dev/null
+++ b/dev-haskell/crypto-cipher-types/crypto-cipher-types-0.0.9.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Generic cryptography cipher types"
+HOMEPAGE="http://github.com/vincenthz/hs-crypto-cipher"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/byteable-0.1.1:=[profile?]
+ >=dev-haskell/securemem-0.1.1:=[profile?]
+ >=dev-lang/ghc-6.10.4:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+"
diff --git a/dev-haskell/crypto-cipher-types/metadata.xml b/dev-haskell/crypto-cipher-types/metadata.xml
new file mode 100644
index 000000000000..24df10502948
--- /dev/null
+++ b/dev-haskell/crypto-cipher-types/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ Generic cryptography cipher types
+ </longdescription>
+ <upstream>
+ <remote-id type="github">vincenthz/hs-crypto-cipher</remote-id>
+ </upstream>
+</pkgmetadata>