summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-04-04 00:31:10 -0400
committerSam James <sam@gentoo.org>2024-04-05 02:20:51 +0100
commit5392281a662b0bda89384e936bde9a455e2a2ae3 (patch)
tree66326d83e2f905b71b6fba4c50ba3c2dc7bbefd6 /dev-embedded/sdcc
parentmedia-gfx/sane-backends: remove confusing and outdated seds (diff)
downloadgentoo-5392281a662b0bda89384e936bde9a455e2a2ae3.tar.gz
gentoo-5392281a662b0bda89384e936bde9a455e2a2ae3.tar.bz2
gentoo-5392281a662b0bda89384e936bde9a455e2a2ae3.zip
dev-embedded/sdcc: mark as LTO-unsafe
Closes: https://bugs.gentoo.org/924691 Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-embedded/sdcc')
-rw-r--r--dev-embedded/sdcc/sdcc-4.3.0-r1.ebuild9
-rw-r--r--dev-embedded/sdcc/sdcc-9999.ebuild9
2 files changed, 14 insertions, 4 deletions
diff --git a/dev-embedded/sdcc/sdcc-4.3.0-r1.ebuild b/dev-embedded/sdcc/sdcc-4.3.0-r1.ebuild
index c317c061b57d..3aa25dab19f1 100644
--- a/dev-embedded/sdcc/sdcc-4.3.0-r1.ebuild
+++ b/dev-embedded/sdcc/sdcc-4.3.0-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit autotools
+inherit autotools flag-o-matic
if [[ ${PV} == "9999" ]] ; then
ESVN_REPO_URI="https://svn.code.sf.net/p/sdcc/code/trunk/sdcc"
@@ -110,6 +110,11 @@ src_prepare() {
}
src_configure() {
+ # -Werror=odr, -Werror=lto-type-mismatch
+ # https://bugs.gentoo.org/924691
+ # https://sourceforge.net/p/sdcc/bugs/3725/
+ filter-lto
+
local myeconfargs=(
ac_cv_prog_STRIP=true
--without-ccache
diff --git a/dev-embedded/sdcc/sdcc-9999.ebuild b/dev-embedded/sdcc/sdcc-9999.ebuild
index f2689c566ba0..72705ab05c30 100644
--- a/dev-embedded/sdcc/sdcc-9999.ebuild
+++ b/dev-embedded/sdcc/sdcc-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit autotools
+inherit autotools flag-o-matic
if [[ ${PV} == "9999" ]] ; then
ESVN_REPO_URI="https://svn.code.sf.net/p/sdcc/code/trunk/sdcc"
@@ -95,6 +95,11 @@ src_prepare() {
}
src_configure() {
+ # -Werror=odr, -Werror=lto-type-mismatch
+ # https://bugs.gentoo.org/924691
+ # https://sourceforge.net/p/sdcc/bugs/3725/
+ filter-lto
+
local myeconfargs=(
ac_cv_prog_STRIP=true
--without-ccache