summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-dotnet/webkit-sharp
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-dotnet/webkit-sharp')
-rw-r--r--dev-dotnet/webkit-sharp/Manifest1
-rw-r--r--dev-dotnet/webkit-sharp/files/webkit-sharp-0.3-webkit14.patch9
-rw-r--r--dev-dotnet/webkit-sharp/metadata.xml5
-rw-r--r--dev-dotnet/webkit-sharp/webkit-sharp-0.3-r1.ebuild33
4 files changed, 48 insertions, 0 deletions
diff --git a/dev-dotnet/webkit-sharp/Manifest b/dev-dotnet/webkit-sharp/Manifest
new file mode 100644
index 000000000000..06586116225c
--- /dev/null
+++ b/dev-dotnet/webkit-sharp/Manifest
@@ -0,0 +1 @@
+DIST webkit-sharp-0.3.tar.bz2 88972 SHA256 6633630b6e4834b0f93726570d1c97e884470e3c400ae929cca2f1376b7b959a SHA512 3a70b41a16024d0682328bcd59d7f99f51a0c191d63a96a4c3bd66ea3e8fb7dea1e85b4934ed3d98c5ae15b69b7745c273f78ad94610653e9f669ffaddc20231 WHIRLPOOL 71dc5d23171603b011322e6aa07dd3b77585ee1311c74ca2cc376f4e06f880a51f7fad60a4cacf20ef2905e1afbc21af7a65991c78e0d8dc715abb78fa64b7d5
diff --git a/dev-dotnet/webkit-sharp/files/webkit-sharp-0.3-webkit14.patch b/dev-dotnet/webkit-sharp/files/webkit-sharp-0.3-webkit14.patch
new file mode 100644
index 000000000000..21f40d4424e4
--- /dev/null
+++ b/dev-dotnet/webkit-sharp/files/webkit-sharp-0.3-webkit14.patch
@@ -0,0 +1,9 @@
+diff --git a/sources/webkit-sharp.dll.config.in b/sources/webkit-sharp.dll.config.in
+index 75788f8..4220311 100644
+--- a/sources/webkit-sharp.dll.config.in
++++ b/sources/webkit-sharp.dll.config.in
+@@ -1,3 +1,3 @@
+ <configuration>
+- <dllmap dll="webkit-1.0" target="webkit-1.0@LIB_PREFIX@.2@LIB_SUFFIX@"/>
++ <dllmap dll="webkit-1.0" target="libwebkitgtk-1.0@LIB_PREFIX@.0@LIB_SUFFIX@"/>
+ </configuration>
diff --git a/dev-dotnet/webkit-sharp/metadata.xml b/dev-dotnet/webkit-sharp/metadata.xml
new file mode 100644
index 000000000000..e85974a7fa17
--- /dev/null
+++ b/dev-dotnet/webkit-sharp/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>dotnet</herd>
+</pkgmetadata>
diff --git a/dev-dotnet/webkit-sharp/webkit-sharp-0.3-r1.ebuild b/dev-dotnet/webkit-sharp/webkit-sharp-0.3-r1.ebuild
new file mode 100644
index 000000000000..436b0ed4c75a
--- /dev/null
+++ b/dev-dotnet/webkit-sharp/webkit-sharp-0.3-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit mono multilib eutils
+
+DESCRIPTION="WebKit-gtk bindings for Mono"
+HOMEPAGE="http://www.mono-project.com/"
+SRC_URI="http://mono.ximian.com/monobuild/preview/sources/webkit-sharp/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE=""
+
+DEPEND=">=dev-lang/mono-2
+ >=net-libs/webkit-gtk-1.4:2
+ dev-dotnet/gtk-sharp:2"
+
+RDEPEND="${DEPEND}"
+
+MAKEOPTS="${MAKEOPTS} -j1"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-webkit14.patch"
+}
+
+src_install() {
+ default
+ mono_multilib_comply
+}