summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-10-08 00:06:41 +0200
committerMaciej Barć <xgqt@gentoo.org>2022-10-08 00:42:14 +0200
commitc2a73fc635a5543ca87a317b64ed32ca8b76c9b9 (patch)
treec150e070d0a0a03ffcf9e78c182b0c52f98f915e /dev-dotnet/dotnet-sdk-bin
parentmedia-gfx/gnome-photos: Version bump to 43.0 (diff)
downloadgentoo-c2a73fc635a5543ca87a317b64ed32ca8b76c9b9.tar.gz
gentoo-c2a73fc635a5543ca87a317b64ed32ca8b76c9b9.tar.bz2
gentoo-c2a73fc635a5543ca87a317b64ed32ca8b76c9b9.zip
dev-dotnet/dotnet-sdk-bin: add ICU dependency
putting ICU in optfeature was a bad idea Bug: https://bugs.gentoo.org/874810 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-dotnet/dotnet-sdk-bin')
-rw-r--r--dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-3.1.422-r1.ebuild (renamed from dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-3.1.422.ebuild)9
-rw-r--r--dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-3.1.423-r1.ebuild (renamed from dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-3.1.423.ebuild)9
-rw-r--r--dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-5.0.408-r1.ebuild (renamed from dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-5.0.408.ebuild)9
-rw-r--r--dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-6.0.400-r1.ebuild (renamed from dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-6.0.401.ebuild)9
-rw-r--r--dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-6.0.401-r1.ebuild (renamed from dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-6.0.400.ebuild)9
5 files changed, 5 insertions, 40 deletions
diff --git a/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-3.1.422.ebuild b/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-3.1.422-r1.ebuild
index 595560460cba..ca7f74f1a41d 100644
--- a/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-3.1.422.ebuild
+++ b/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-3.1.422-r1.ebuild
@@ -3,8 +3,6 @@
EAPI=8
-inherit optfeature
-
MY_PV="${PV}"
DESCRIPTION=".NET is a free, cross-platform, open-source developer platform"
@@ -25,6 +23,7 @@ QA_PREBUILT="*"
RESTRICT+=" splitdebug"
RDEPEND="
app-crypt/mit-krb5:0/0
+ dev-libs/icu
dev-util/lttng-ust:0
sys-libs/zlib:0/1
dotnet-symlink? ( !dev-dotnet/dotnet-sdk[dotnet-symlink(+)] )
@@ -48,9 +47,3 @@ src_install() {
doenvd "${T}/90${PN}-${SLOT}"
fi
}
-
-pkg_postinst() {
- # For bug #833281 Also, MS docs:
- # https://docs.microsoft.com/en-us/dotnet/core/runtime-config/globalization
- optfeature "globalization support" dev-libs/icu
-}
diff --git a/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-3.1.423.ebuild b/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-3.1.423-r1.ebuild
index 595560460cba..ca7f74f1a41d 100644
--- a/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-3.1.423.ebuild
+++ b/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-3.1.423-r1.ebuild
@@ -3,8 +3,6 @@
EAPI=8
-inherit optfeature
-
MY_PV="${PV}"
DESCRIPTION=".NET is a free, cross-platform, open-source developer platform"
@@ -25,6 +23,7 @@ QA_PREBUILT="*"
RESTRICT+=" splitdebug"
RDEPEND="
app-crypt/mit-krb5:0/0
+ dev-libs/icu
dev-util/lttng-ust:0
sys-libs/zlib:0/1
dotnet-symlink? ( !dev-dotnet/dotnet-sdk[dotnet-symlink(+)] )
@@ -48,9 +47,3 @@ src_install() {
doenvd "${T}/90${PN}-${SLOT}"
fi
}
-
-pkg_postinst() {
- # For bug #833281 Also, MS docs:
- # https://docs.microsoft.com/en-us/dotnet/core/runtime-config/globalization
- optfeature "globalization support" dev-libs/icu
-}
diff --git a/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-5.0.408.ebuild b/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-5.0.408-r1.ebuild
index 0a495504107e..3d26e751070c 100644
--- a/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-5.0.408.ebuild
+++ b/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-5.0.408-r1.ebuild
@@ -3,8 +3,6 @@
EAPI=8
-inherit optfeature
-
MY_PV="${PV}"
DESCRIPTION=".NET is a free, cross-platform, open-source developer platform"
@@ -25,6 +23,7 @@ QA_PREBUILT="*"
RESTRICT+=" splitdebug"
RDEPEND="
app-crypt/mit-krb5:0/0
+ dev-libs/icu
dev-util/lttng-ust:0
sys-libs/zlib:0/1
dotnet-symlink? (
@@ -51,9 +50,3 @@ src_install() {
doenvd "${T}/90${PN}-${SLOT}"
fi
}
-
-pkg_postinst() {
- # For bug #833281 Also, MS docs:
- # https://docs.microsoft.com/en-us/dotnet/core/runtime-config/globalization
- optfeature "globalization support" dev-libs/icu
-}
diff --git a/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-6.0.401.ebuild b/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-6.0.400-r1.ebuild
index bfdeb499a7c5..462d299e4691 100644
--- a/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-6.0.401.ebuild
+++ b/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-6.0.400-r1.ebuild
@@ -3,8 +3,6 @@
EAPI=8
-inherit optfeature
-
MY_PV="${PV}"
DESCRIPTION=".NET is a free, cross-platform, open-source developer platform"
@@ -25,6 +23,7 @@ QA_PREBUILT="*"
RESTRICT+=" splitdebug"
RDEPEND="
app-crypt/mit-krb5:0/0
+ dev-libs/icu
dev-util/lttng-ust:0
sys-libs/zlib:0/1
dotnet-symlink? (
@@ -57,9 +56,3 @@ src_install() {
doenvd "${T}/90${PN}-${SLOT}"
fi
}
-
-pkg_postinst() {
- # For bug #833281 Also, MS docs:
- # https://docs.microsoft.com/en-us/dotnet/core/runtime-config/globalization
- optfeature "globalization support" dev-libs/icu
-}
diff --git a/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-6.0.400.ebuild b/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-6.0.401-r1.ebuild
index bfdeb499a7c5..462d299e4691 100644
--- a/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-6.0.400.ebuild
+++ b/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-6.0.401-r1.ebuild
@@ -3,8 +3,6 @@
EAPI=8
-inherit optfeature
-
MY_PV="${PV}"
DESCRIPTION=".NET is a free, cross-platform, open-source developer platform"
@@ -25,6 +23,7 @@ QA_PREBUILT="*"
RESTRICT+=" splitdebug"
RDEPEND="
app-crypt/mit-krb5:0/0
+ dev-libs/icu
dev-util/lttng-ust:0
sys-libs/zlib:0/1
dotnet-symlink? (
@@ -57,9 +56,3 @@ src_install() {
doenvd "${T}/90${PN}-${SLOT}"
fi
}
-
-pkg_postinst() {
- # For bug #833281 Also, MS docs:
- # https://docs.microsoft.com/en-us/dotnet/core/runtime-config/globalization
- optfeature "globalization support" dev-libs/icu
-}