summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-db/unixODBC
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-db/unixODBC')
-rw-r--r--dev-db/unixODBC/Manifest2
-rw-r--r--dev-db/unixODBC/files/unixODBC-2.3.0-sqldriverconnect.patch27
-rw-r--r--dev-db/unixODBC/metadata.xml12
-rw-r--r--dev-db/unixODBC/unixODBC-2.3.1-r1.ebuild49
-rw-r--r--dev-db/unixODBC/unixODBC-2.3.1.ebuild46
-rw-r--r--dev-db/unixODBC/unixODBC-2.3.2-r1.ebuild52
-rw-r--r--dev-db/unixODBC/unixODBC-2.3.2-r2.ebuild53
7 files changed, 241 insertions, 0 deletions
diff --git a/dev-db/unixODBC/Manifest b/dev-db/unixODBC/Manifest
new file mode 100644
index 000000000000..96eb2c38dbee
--- /dev/null
+++ b/dev-db/unixODBC/Manifest
@@ -0,0 +1,2 @@
+DIST unixODBC-2.3.1.tar.gz 1813380 SHA256 1f5be3edecff9e31072ef738ea1d8019594c4f0c2e3ab427e6eef153491db6a2 SHA512 682a4c58febb923491aba4cad8d07228330e5dccb7b8969e0a9d99f92cd90757bd931441f3391c8562ade89f3cfc82416bad8c63d6c0e60b55d0101829e8b872 WHIRLPOOL c3bae729f8af2d4a2680768f00e91044ea32fedc4e677230db3c6a321e8e41964b57b3f850aef6d8213c611f3d0b62822d3c68b8f1b9a11877403891d310e32a
+DIST unixODBC-2.3.2.tar.gz 1849173 SHA256 9c3459742f25df5aa3c10a61429bde51a6d4f11552c03095f1d33d7eb02b5c9a SHA512 31d705bf3dcaff6707d5680235b34e4d265a084b1de9e1b2ed3bbee1e1dfefdb4437fe3e1736b84e446d1927ec7622296d9e9b129052cb35f4b63b0bd79ccd13 WHIRLPOOL 05b8fe927a148a0b7ec7abecbac6f5370e904c669b5b0cc58840f7c2302e1df62901a1a627221057be6d4b8b90772854fe3db6e5fda2a5df02970073416ef5f0
diff --git a/dev-db/unixODBC/files/unixODBC-2.3.0-sqldriverconnect.patch b/dev-db/unixODBC/files/unixODBC-2.3.0-sqldriverconnect.patch
new file mode 100644
index 000000000000..abcce61106d6
--- /dev/null
+++ b/dev-db/unixODBC/files/unixODBC-2.3.0-sqldriverconnect.patch
@@ -0,0 +1,27 @@
+http://bugs.gentoo.org/show_bug.cgi?id=358611
+--- unixODBC-2.3.0.orig/DriverManager/SQLDriverConnect.c 2011-04-02 21:56:19.889301819 +0400
++++ unixODBC-2.3.0/DriverManager/SQLDriverConnect.c 2011-04-02 21:58:37.129102095 +0400
+@@ -639,7 +639,7 @@
+ {
+ DMHDBC connection = (DMHDBC)hdbc;
+ struct con_struct con_struct;
+- char *driver, *dsn = NULL, *filedsn, *tsavefile, savefile[ 128 ];
++ char *driver, *dsn = NULL, *filedsn, *tsavefile, savefile[ INI_MAX_PROPERTY_VALUE + 1 ];
+ char lib_name[ INI_MAX_PROPERTY_VALUE + 1 ];
+ char driver_name[ INI_MAX_PROPERTY_VALUE + 1 ];
+ SQLRETURN ret_from_connect;
+@@ -944,7 +944,13 @@
+ tsavefile = __get_attribute_value( &con_struct, "SAVEFILE" );
+ if ( tsavefile )
+ {
+- strcpy( savefile, tsavefile );
++ if ( strlen( tsavefile ) > INI_MAX_PROPERTY_VALUE ) {
++ memcpy( savefile, tsavefile, INI_MAX_PROPERTY_VALUE );
++ savefile[ INI_MAX_PROPERTY_VALUE ] = '\0';
++ }
++ else {
++ strcpy( savefile, tsavefile );
++ }
+ }
+ else
+ {
diff --git a/dev-db/unixODBC/metadata.xml b/dev-db/unixODBC/metadata.xml
new file mode 100644
index 000000000000..b77626c0cda6
--- /dev/null
+++ b/dev-db/unixODBC/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>neurogeek@gentoo.org</email>
+ <name>Jesus Rivero</name>
+ </maintainer>
+ <use>
+ <flag name="minimal">Disable bundled drivers and extra libraries (most users don't need these)</flag>
+ <flag name="odbcmanual">Administrator, Internal Structure, Programmer and User documentation</flag>
+ </use>
+</pkgmetadata>
diff --git a/dev-db/unixODBC/unixODBC-2.3.1-r1.ebuild b/dev-db/unixODBC/unixODBC-2.3.1-r1.ebuild
new file mode 100644
index 000000000000..644d2b396b2f
--- /dev/null
+++ b/dev-db/unixODBC/unixODBC-2.3.1-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit libtool
+
+DESCRIPTION="A complete ODBC driver manager"
+HOMEPAGE="http://www.unixodbc.org/"
+SRC_URI="http://ftp.unixodbc.org/pub/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="+minimal odbcmanual static-libs unicode"
+
+RDEPEND=">=sys-devel/libtool-2.2.6b
+ >=sys-libs/readline-6.1
+ >=sys-libs/ncurses-5.7-r7
+ virtual/libiconv"
+DEPEND="${RDEPEND}
+ sys-devel/flex"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+src_prepare() {
+ elibtoolize
+}
+
+src_configure() {
+ # --enable-driver-conf is --enable-driverc as per configure.in
+ econf \
+ --sysconfdir="${EPREFIX}"/etc/${PN} \
+ --enable-iconv \
+ $(use_enable static-libs static) \
+ $(use_enable !minimal drivers) \
+ $(use_enable !minimal driverc) \
+ $(use_with unicode iconv-char-enc UTF8) \
+ $(use_with unicode iconv-ucode-enc UTF16LE)
+}
+
+src_install() {
+ default
+
+ use prefix && dodoc README*
+ use odbcmanual && dohtml -a css,gif,html,sql,vsd -r doc/*
+
+ find "${ED}" -name '*.la' -exec sed -i -e "/^dependency_libs/s:=.*:='':" {} +
+}
diff --git a/dev-db/unixODBC/unixODBC-2.3.1.ebuild b/dev-db/unixODBC/unixODBC-2.3.1.ebuild
new file mode 100644
index 000000000000..ad3b416777be
--- /dev/null
+++ b/dev-db/unixODBC/unixODBC-2.3.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit libtool
+
+DESCRIPTION="A complete ODBC driver manager"
+HOMEPAGE="http://www.unixodbc.org/"
+SRC_URI="http://ftp.unixodbc.org/pub/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="+minimal odbcmanual static-libs"
+
+RDEPEND=">=sys-devel/libtool-2.2.6b
+ >=sys-libs/readline-6.1
+ >=sys-libs/ncurses-5.7-r7
+ virtual/libiconv"
+DEPEND="${RDEPEND}
+ sys-devel/flex"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+src_prepare() {
+ elibtoolize
+}
+
+src_configure() {
+ # --enable-driver-conf is --enable-driverc as per configure.in
+ econf \
+ --sysconfdir="${EPREFIX}"/etc/${PN} \
+ $(use_enable static-libs static) \
+ $(use_enable !minimal drivers) \
+ $(use_enable !minimal driverc)
+}
+
+src_install() {
+ default
+
+ use prefix && dodoc README*
+ use odbcmanual && dohtml -a css,gif,html,sql,vsd -r doc/*
+
+ find "${ED}" -name '*.la' -exec sed -i -e "/^dependency_libs/s:=.*:='':" {} +
+}
diff --git a/dev-db/unixODBC/unixODBC-2.3.2-r1.ebuild b/dev-db/unixODBC/unixODBC-2.3.2-r1.ebuild
new file mode 100644
index 000000000000..c309b952e41d
--- /dev/null
+++ b/dev-db/unixODBC/unixODBC-2.3.2-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit libtool autotools-multilib eutils
+
+DESCRIPTION="A complete ODBC driver manager"
+HOMEPAGE="http://www.unixodbc.org/"
+SRC_URI="http://ftp.unixodbc.org/pub/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="+minimal odbcmanual static-libs unicode"
+
+RDEPEND="|| (
+ dev-libs/libltdl:0[${MULTILIB_USEDEP}]
+ >=sys-devel/libtool-2.4.2-r1[${MULTILIB_USEDEP}]
+ )
+ >=sys-libs/readline-6.2_p5-r1[${MULTILIB_USEDEP}]
+ >=sys-libs/ncurses-5.9-r3[${MULTILIB_USEDEP}]
+ >=virtual/libiconv-0-r1[${MULTILIB_USEDEP}]
+ abi_x86_32? ( !app-emulation/emul-linux-x86-db[-abi_x86_32(-)] )"
+DEPEND="${RDEPEND}
+ sys-devel/flex"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+MULTILIB_WRAPPED_HEADERS=( /usr/include/unixodbc_conf.h )
+
+src_configure() {
+ # --enable-driver-conf is --enable-driverc as per configure.in
+ myeconfargs=(
+ --sysconfdir="${EPREFIX}"/etc/${PN}
+ --enable-iconv
+ $(use_enable static-libs static)
+ $(use_enable !minimal drivers)
+ $(use_enable !minimal driverc)
+ $(use_with unicode iconv-char-enc UTF8)
+ $(use_with unicode iconv-ucode-enc UTF16LE)
+ )
+ autotools-multilib_src_configure
+}
+
+multilib_src_install_all() {
+ einstalldocs
+
+ use prefix && dodoc README*
+ use odbcmanual && dohtml -a css,gif,html,sql,vsd -r doc/*
+
+ find "${ED}" -name '*.la' -exec sed -i -e "/^dependency_libs/s:=.*:='':" {} +
+}
diff --git a/dev-db/unixODBC/unixODBC-2.3.2-r2.ebuild b/dev-db/unixODBC/unixODBC-2.3.2-r2.ebuild
new file mode 100644
index 000000000000..a4c5d4af6530
--- /dev/null
+++ b/dev-db/unixODBC/unixODBC-2.3.2-r2.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit libtool autotools-multilib eutils
+
+DESCRIPTION="A complete ODBC driver manager"
+HOMEPAGE="http://www.unixodbc.org/"
+SRC_URI="http://ftp.unixodbc.org/pub/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="+minimal odbcmanual static-libs unicode"
+
+RDEPEND="|| (
+ dev-libs/libltdl:0[${MULTILIB_USEDEP}]
+ >=sys-devel/libtool-2.4.2-r1[${MULTILIB_USEDEP}]
+ )
+ >=sys-libs/readline-6.2_p5-r1[${MULTILIB_USEDEP}]
+ >=sys-libs/ncurses-5.9-r3[${MULTILIB_USEDEP}]
+ >=virtual/libiconv-0-r1[${MULTILIB_USEDEP}]
+ abi_x86_32? ( !app-emulation/emul-linux-x86-db[-abi_x86_32(-)] )"
+DEPEND="${RDEPEND}
+ sys-devel/flex"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+MULTILIB_CHOST_TOOLS=( /usr/bin/odbc_config )
+MULTILIB_WRAPPED_HEADERS=( /usr/include/unixodbc_conf.h )
+
+src_configure() {
+ # --enable-driver-conf is --enable-driverc as per configure.in
+ myeconfargs=(
+ --sysconfdir="${EPREFIX}"/etc/${PN}
+ --enable-iconv
+ $(use_enable static-libs static)
+ $(use_enable !minimal drivers)
+ $(use_enable !minimal driverc)
+ $(use_with unicode iconv-char-enc UTF8)
+ $(use_with unicode iconv-ucode-enc UTF16LE)
+ )
+ autotools-multilib_src_configure
+}
+
+multilib_src_install_all() {
+ einstalldocs
+
+ use prefix && dodoc README*
+ use odbcmanual && dohtml -a css,gif,html,sql,vsd -r doc/*
+
+ find "${ED}" -name '*.la' -exec sed -i -e "/^dependency_libs/s:=.*:='':" {} +
+}