summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-07-08 15:17:50 +0100
committerSam James <sam@gentoo.org>2024-07-08 15:17:50 +0100
commita6b3dbc24056988d7cc02f29dd0dccd8844dd9d9 (patch)
tree6612863706e000498d50e7ad29fb4d76e9d89630 /dev-cpp
parentdev-python/nanobind: fixup deps (diff)
downloadgentoo-a6b3dbc24056988d7cc02f29dd0dccd8844dd9d9.tar.gz
gentoo-a6b3dbc24056988d7cc02f29dd0dccd8844dd9d9.tar.bz2
gentoo-a6b3dbc24056988d7cc02f29dd0dccd8844dd9d9.zip
dev-cpp/robin-map: don't build tests w/ -Werror
Closes: https://bugs.gentoo.org/935749 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/robin-map/robin-map-1.3.0.ebuild5
-rw-r--r--dev-cpp/robin-map/robin-map-9999.ebuild5
2 files changed, 8 insertions, 2 deletions
diff --git a/dev-cpp/robin-map/robin-map-1.3.0.ebuild b/dev-cpp/robin-map/robin-map-1.3.0.ebuild
index a476d88fd8ce..5ebd0b902e42 100644
--- a/dev-cpp/robin-map/robin-map-1.3.0.ebuild
+++ b/dev-cpp/robin-map/robin-map-1.3.0.ebuild
@@ -27,7 +27,10 @@ BDEPEND="
src_test() {
cd tests || die
- sed -i -e '/Boost_USE_STATIC_LIBS/d' CMakeLists.txt || die
+ sed -i \
+ -e '/Boost_USE_STATIC_LIBS/d' \
+ -e 's/-Werror//' \
+ CMakeLists.txt || die
cmake -S "${S}/tests" -B . -GNinja || die
eninja
./tsl_robin_map_tests || die
diff --git a/dev-cpp/robin-map/robin-map-9999.ebuild b/dev-cpp/robin-map/robin-map-9999.ebuild
index a476d88fd8ce..5ebd0b902e42 100644
--- a/dev-cpp/robin-map/robin-map-9999.ebuild
+++ b/dev-cpp/robin-map/robin-map-9999.ebuild
@@ -27,7 +27,10 @@ BDEPEND="
src_test() {
cd tests || die
- sed -i -e '/Boost_USE_STATIC_LIBS/d' CMakeLists.txt || die
+ sed -i \
+ -e '/Boost_USE_STATIC_LIBS/d' \
+ -e 's/-Werror//' \
+ CMakeLists.txt || die
cmake -S "${S}/tests" -B . -GNinja || die
eninja
./tsl_robin_map_tests || die