summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz@gentoo.org>2024-08-20 23:48:34 -0400
committerEli Schwartz <eschwartz@gentoo.org>2024-08-20 23:48:34 -0400
commit8c7941ef6d72ebd63de340dfa1ec3f57c23b9b8d (patch)
tree0b386d625431a14ad5f175b32f8635444d238709 /dev-cpp
parentdev-python/uv: Make reqwest-middleware patching more flexible (diff)
downloadgentoo-8c7941ef6d72ebd63de340dfa1ec3f57c23b9b8d.tar.gz
gentoo-8c7941ef6d72ebd63de340dfa1ec3f57c23b9b8d.tar.bz2
gentoo-8c7941ef6d72ebd63de340dfa1ec3f57c23b9b8d.zip
dev-cpp/benchmark: do not require any PYTHON_SINGLE_TARGET without tools
We only perform the python-single-r1 dance when `use tools`, and similarly in RDEPEND via USE-conditional dependencies. But REQUIRED_USE was unconditionally done, when it too should have been guarded by the USE flag. Present since the initial implementation of python tool support. Fixes: 6f8ef24af37e572d317fac58ea8eabab64a3f3a8 Bug: https://bugs.gentoo.org/938237 Signed-off-by: Eli Schwartz <eschwartz@gentoo.org>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/benchmark/benchmark-1.9.0.ebuild2
1 files changed, 1 insertions, 1 deletions
diff --git a/dev-cpp/benchmark/benchmark-1.9.0.ebuild b/dev-cpp/benchmark/benchmark-1.9.0.ebuild
index ce4ceb735412..46af0a1dbe0f 100644
--- a/dev-cpp/benchmark/benchmark-1.9.0.ebuild
+++ b/dev-cpp/benchmark/benchmark-1.9.0.ebuild
@@ -15,7 +15,7 @@ SLOT="0/$(ver_cut 1)"
KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~x86"
IUSE="doc +exceptions libcxx libpfm lto test +tools"
RESTRICT="!test? ( test )"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+REQUIRED_USE="tools? ( ${PYTHON_REQUIRED_USE} )"
DEPEND="
libcxx? ( sys-libs/libcxx[${MULTILIB_USEDEP}] )